socket_io_client 0.8.2

  • README.md
  • Installing
  • Versions
  • 81

socket.io-client-dart

Port of awesome JavaScript Node.js library - Socket.io-client v2.0.1 - in Dart

Usage

import 'package:socket_io/socket_io.dart';
import 'package:socket_io_client/socket_io_client.dart' as IO;

main() {
    // Dart server
    var io = new Server();
    var nsp = io.of('/some');
    nsp.on('connection', (Socket client) {
      print('connection /some');
      client.on('msg', (data) {
        print('data from /some => $data');
        client.emit('fromServer', "ok 2");
      });
    });
      io.on('connection', (Socket client) {
        print('connection default namespace');
        client.on('msg', (data) {
          print('data from default => $data');
          client.emit('fromServer', "ok");
        });
      });
      io.listen(3000);

    // Dart client
    IO.Socket socket = IO.io('http://localhost:3000');
    socket.on('connect', (_) {
     print('connect');
     socket.emit('msg', 'test');
    });
    socket.on('event', (data) => print(data));
    socket.on('disconnect', (_) => print('disconnect'));
    socket.on('fromServer', (_) => print(_));
}

Notes to Contributors

Fork socket.io-client-dart

If you'd like to contribute back to the core, you can fork this repository and send us a pull request, when it is ready.

If you are new to Git or GitHub, please read this guide first.

Who Uses

  • Quire - a simple, collaborative, multi-level task management tool.
  • KEIKAI - a web spreadsheet for Big Data.

Socket.io Dart Server

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  socket_io_client: ^0.8.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:socket_io_client/socket_io_client.dart';
  
Version Uploaded Documentation Archive
0.8.2 Jun 4, 2018 Go to the documentation of socket_io_client 0.8.2 Download socket_io_client 0.8.2 archive
0.8.1 May 25, 2018 Go to the documentation of socket_io_client 0.8.1 Download socket_io_client 0.8.1 archive
0.8.0 Apr 9, 2018 Go to the documentation of socket_io_client 0.8.0 Download socket_io_client 0.8.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
77
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
64
Overall:
Weighted score of the above. [more]
81
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because socket_io_client depends on socket_io any which requires SDK version >=1.0.0 <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use socket_io_client.dart.

Format lib/socket_io_client.dart.

Run dartfmt to format lib/socket_io_client.dart.

Format lib/src/engine/parseqs.dart.

Run dartfmt to format lib/src/engine/parseqs.dart.

Fix additional 9 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/engine/socket.dart (Run dartfmt to format lib/src/engine/socket.dart.)
  • lib/src/engine/transport/jsonp_transport.dart (Run dartfmt to format lib/src/engine/transport/jsonp_transport.dart.)
  • lib/src/engine/transport/polling_transport.dart (Run dartfmt to format lib/src/engine/transport/polling_transport.dart.)
  • lib/src/engine/transport/transports.dart (Run dartfmt to format lib/src/engine/transport/transports.dart.)
  • lib/src/engine/transport/websocket_transport.dart (Run dartfmt to format lib/src/engine/transport/websocket_transport.dart.)
  • lib/src/engine/transport/xhr_transport.dart (Run dartfmt to format lib/src/engine/transport/xhr_transport.dart.)
  • lib/src/manager.dart (Run dartfmt to format lib/src/manager.dart.)
  • lib/src/on.dart (Run dartfmt to format lib/src/on.dart.)
  • lib/src/socket.dart (Run dartfmt to format lib/src/socket.dart.)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0