solarium_tools 0.0.3

  • README.md
  • Installing
  • Versions
  • 0

solarium_tools

A command-line application with support tools for SolariumVR.

Install

Use the pub global command to install this into your system.

$ pub global activate solarium_tools

Commands

solarium serve

Runs a simple http server. The default document is index.dart

  • --port - Set the port. Defaults to 8080.
  • --path - Set the path to serve. Defaults to cwd.
  • --host - Hostname to listen on. Defaults to localhost.
  • --allow-origin - Value for the 'Access-Control-Allow-Origin' header.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate solarium_tools

2. Use it

The package has the following executables:


$ solarium

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  solarium_tools: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:solarium_tools/solarium_tools.dart';
  
Version Uploaded Documentation Archive
0.0.3 Nov 10, 2017 Go to the documentation of solarium_tools 0.0.3 Download solarium_tools 0.0.3 archive
0.0.2 Sep 8, 2017 Go to the documentation of solarium_tools 0.0.2 Download solarium_tools 0.0.2 archive
0.0.1 Sep 8, 2017 Go to the documentation of solarium_tools 0.0.1 Download solarium_tools 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0