solitaire 0.3.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

A Dart version of Solitaire, the classic card game.

Demo

Enjoy the online demo!

Solitaire

0.3.0 - Jan 25, 2014

  • Updated README.md, LICENSE.txt and CHANGELOG.md

0.2.0 - Nov 08, 2013

  • Replaced JSON package with the new convert one
  • Replaced deprecated query function with querySelector
  • Replaced deprecated context2d getter with context2D
  • Changed html.OptionElement constructor parameters, now are optionals
  • Removed dart2js warning
  • Ready for Dart 1.0.0!

0.1.2 - Mar 25, 2013

  • Removed deprecated List.fixedLength constructor
  • Changed offsetX/Y and pageX/Y for offset.x/y and page.x/y
  • Changed deprecated List.getRange for sublist
  • Changed Canvas.drawImage for drawImageScaled/FromSource

0.1.1 - Feb 21, 2013

  • M3 update
  • Added CHANGES.md

0.1.0 - Feb 01, 2013

  • First Dart pub package release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  solitaire: ^0.3.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:solitaire/solitaire.dart';
  
Version Uploaded Documentation Archive
0.3.1 Jan 25, 2014 Go to the documentation of solitaire 0.3.1 Download solitaire 0.3.1 archive
0.3.0 Jan 25, 2014 Go to the documentation of solitaire 0.3.0 Download solitaire 0.3.0 archive
0.2.0 Nov 8, 2013 Go to the documentation of solitaire 0.2.0 Download solitaire 0.2.0 archive
0.1.2 Mar 25, 2013 Go to the documentation of solitaire 0.1.2 Download solitaire 0.1.2 archive
0.1.1 Feb 21, 2013 Go to the documentation of solitaire 0.1.1 Download solitaire 0.1.1 archive
0.1.0 Feb 1, 2013 Go to the documentation of solitaire 0.1.0 Download solitaire 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because solitaire depends on browser >=0.3.1+1 which requires SDK version <2.0.0, version solving failed.

Package is too old.

The package was released more than two years ago.

Homepage does not exists.

We were unable to access http://code.google.com/p/dart-solitaire/ at the time of the analysis.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use solitaire.dart.

Format lib/src/board.dart.

Run dartfmt to format lib/src/board.dart.

Format lib/src/bouncer.dart.

Run dartfmt to format lib/src/bouncer.dart.

Format lib/src/card.dart.

Run dartfmt to format lib/src/card.dart.

Fix additional 9 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/command.dart (Run dartfmt to format lib/src/command.dart.)
  • lib/src/deck.dart (Run dartfmt to format lib/src/deck.dart.)
  • lib/src/game.dart (Run dartfmt to format lib/src/game.dart.)
  • lib/src/image.dart (Run dartfmt to format lib/src/image.dart.)
  • lib/src/menu.dart (Run dartfmt to format lib/src/menu.dart.)
  • lib/src/pile.dart (Run dartfmt to format lib/src/pile.dart.)
  • lib/src/renderer.dart (Run dartfmt to format lib/src/renderer.dart.)
  • lib/src/settings.dart (Run dartfmt to format lib/src/settings.dart.)
  • lib/src/sprite.dart (Run dartfmt to format lib/src/sprite.dart.)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.1.1