source_transformer 0.1.1

  • Installing
  • Versions
  • 0

source_transformer #

NOTE: This project is not an official Google or dart-lang project

This package is currently in development

Not to be confused with code_transformers or source_gen, source_transformer is a library for building and applying modifications to existing files, primarily .dart source files, and to commit the results of those changes.

Example uses:

  • Writing tools to automatically upgrade deprecated APIs
  • Writing tools to perform mass refactorings
  • Writing tools to perform macros as part of writing new code

An example of creating a binary that removes duplicate imports/exports:

import 'package:source_transformer/source_transformer.dart';

main(List<String> paths) async {
  await runTransformer(const DeduplicateDirectives(), paths);

0.1.1 #

  • Added RemovePatterns and ReplacePatterns

0.1.0 #

  • Initial Commit

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  source_transformer: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:source_transformer/source_transformer.dart';
Version Uploaded Documentation Archive
0.1.1 Dec 20, 2016 Go to the documentation of source_transformer 0.1.1 Download source_transformer 0.1.1 archive
0.1.0 Dec 19, 2016 Go to the documentation of source_transformer 0.1.0 Download source_transformer 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

This package is not analyzed, because it is discontinued.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0