soy 0.0.1

  • README.md
  • Installing
  • Versions
  • 0

soy

version 0.0.1 build status

Parser and AST classes for Closure Templates. This will allow us to finally bring robust server-rendered templates to Dart;

import 'package:soy/soy.dart' as soy;

main() {
    var ast = soy.parse(...);
}

TODO

  • [ ] API Documentation
  • [ ] Expression Parser

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  soy: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:soy/soy.dart';
  
Version Uploaded Documentation Archive
0.0.1 Mar 14, 2017 Go to the documentation of soy 0.0.1 Download soy 0.0.1 archive
0.0.0 Mar 14, 2017 Go to the documentation of soy 0.0.0 Download soy 0.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

We analyzed this package on Dec 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 
 Because soy depends on compiler_tools any which requires SDK version >=1.19.0 <2.0.0, version solving failed.

Health suggestions

Format lib/src/ast/ast_node.dart.

Run dartfmt to format lib/src/ast/ast_node.dart.

Format lib/src/ast/node_member.dart.

Run dartfmt to format lib/src/ast/node_member.dart.

Format lib/src/text/text.dart.

Run dartfmt to format lib/src/text/text.dart.

Format lib/src/text/token_type.dart.

Run dartfmt to format lib/src/text/token_type.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-76.44 points)

The package was released 92 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use soy.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0