sparkline_console 0.0.1

  • Example
  • Installing
  • Versions
  • 50


A library for generating command line sparklines.

Adapted from this Go library.


A simple usage example:

import 'package:sparkline_console/sparkline_console.dart';

main() {
  var sparkLine = new SparkLine();
  print(sparkLine.generate([1, 2, 3, 4, 5, 6, 7, 8])); // ▁▂▃▄▅▆▇█


  • Initial version, created by Stagehand


import 'package:sparkline_console/sparkline_console.dart';

main() {
  var sparkLine = new SparkLine();
  print(sparkLine.generate([1, 2, 3, 4, 5, 6, 7, 8])); // ▁▂▃▄▅▆▇█

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  sparkline_console: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:sparkline_console/sparkline_console.dart';
Version Uploaded Documentation Archive
0.0.1 May 8, 2018 Go to the documentation of sparkline_console 0.0.1 Download sparkline_console 0.0.1 archive


We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
100 / 100
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:sparkline_console/sparkline_console.dart.


  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
Dev dependencies
test ^0.12.0