speakeasy 0.0.2

  • README.md
  • Installing
  • Versions
  • 38


A private pub server for Dart

Build Status



Use cases

  1. Use private packages.

    Allows you to use the pub package system in your company without exposing code to the public, and use your private packages just as easily as public ones.

  2. Cache pub.dartlang.org.

    Reduces latency to users. Packages are cached from pub.dartlang.org and are available as long as the server is running ensuring reliability for CI systems.


Speakeasy was inspired by Sinopia a private npm server and contains a similar configuration process.

1. Depend on it

Add this to your package's pubspec.yaml file:

  speakeasy: "^0.0.2"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:speakeasy/configuration.dart';

import 'package:speakeasy/repository.dart';
Version Uploaded Documentation Archive
0.0.2 Feb 28, 2017 Go to the documentation of speakeasy 0.0.2 Download speakeasy 0.0.2 archive
0.0.1 Feb 28, 2017 Go to the documentation of speakeasy 0.0.1 Download speakeasy 0.0.1 archive


This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 16, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
80 / 100
Reflects how tidy and up-to-date the package is. [more]
72 / 100
Overall score:
Weighted score of the above. [more]


Detected platforms: Flutter, other

Platform components identified in package: io.


  • Fix lib/src/repository/file_repository.dart.

    Strong-mode analysis of lib/src/repository/file_repository.dart failed with the following error:

    line: 29 col: 16
    The function expression type '(Directory) → PackageVersion' isn't of type '(FileSystemEntity) → PackageVersion'. This means its parameter or return type does not match what is expected. Consider changing parameter type(s) or the returned type(s).

  • Fix lib/src/repository/copy_and_write_repository.dart.

    Strong-mode analysis of lib/src/repository/copy_and_write_repository.dart failed with the following error:

    line: 86 col: 3
    Invalid override. The type of 'CopyAndWriteRepository.upload' ('(Stream<List<int>>) → Future<dynamic>') isn't a subtype of 'PackageRepository.upload' ('(Stream<List<int>>) → Future<PackageVersion>').

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 2 error(s) and 0 warning(s).

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use speakeasy.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.12.0 <2.0.0
archive ^1.0.20 1.0.29 1.0.33
args ^0.13.2 0.13.7 1.3.0
http ^0.11.3+2 0.11.3+16
logging ^0.11.1+1 0.11.3+1
pub_server ^0.1.1 0.1.2 0.1.3
resource ^2.1.2 2.1.2
shelf ^0.5.0 0.5.7 0.7.2
Transitive dependencies
async 2.0.3 2.0.4
charcode 1.1.1
collection 1.14.5
convert 1.1.1 2.0.1
crypto 0.9.2+1 2.0.2+1
http_parser 0.0.2+8 3.1.1
mime 0.9.6
path 1.5.1
pub_semver 1.3.2
source_span 1.4.0
stack_trace 1.9.2
string_scanner 0.1.5 1.0.2
typed_data 1.1.5
yaml 2.1.13