spell_corrector 1.0.1

  • README.md
  • Installing
  • Versions
  • 0

spell_corrector #

Port of Peter Norvig's spelling corrector http://norvig.com/spell-correct.html

Usage #

import 'package:spell_corrector/spell_corrector.dart';
main() {
      var sourceData = "spelling spelunking";
      var corrector = new SpellCorrector(sourceData);
      print(corrector.correction("speling")); // prints "spelling"
}

Command line interface #

run pub global activate spell_corrector to activate:

$ spell_corrector speling
$ spelling

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate spell_corrector

2. Use it

The package has the following executables:


$ spell_corrector

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  spell_corrector: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:spell_corrector/spell_corrector.dart';
  
Version Uploaded Documentation Archive
1.0.1 Apr 11, 2017 Go to the documentation of spell_corrector 1.0.1 Download spell_corrector 1.0.1 archive
1.0.0 Dec 16, 2016 Go to the documentation of spell_corrector 1.0.0 Download spell_corrector 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.