sphere_bottom_navigation_bar 1.0.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new65

Sphere Bottom Navigation Bar #

Sphere Bottom Navigation Bar is flutter package, You can create beautiful awesome degined bottom navigation bar with importing this library

Getting Started #

1. Add the dependencies to [pubspec.yaml]

dependencies:
   sphere_bottom_navigation_bar: ^1.0.0

2. Install it #

You can install packages from the command line:

$ flutter packages get

3. Import package #

import  'package:sphere_bottom_navigation_bar/sphere_bottom_navigation_bar.dart';

4. Example: #

bottomNavigationBar: SphereBottomNavigationBar(  
  defaultSelectedItem: 0,  
  sheetRadius: BorderRadius.only(  
      topLeft: Radius.circular(20), topRight: Radius.circular(20)),  
  onItemPressed: (index) => setState(() {  
        print('Selected item is - $index');  
      }),   
  navigationItems: [  
    BuildNavigationItem(  
      tooltip: 'Home',  
  itemColor: Color(0xFFFFD6B2),  
  icon: Icon(Icons.home),  
  selectedItemColor: Color(0xFFFFD6B2),  
  ),  
  BuildNavigationItem(  
      tooltip: 'Chat',  
  itemColor: Color(0xFFB2F4FF),  
  icon: Icon(Icons.chat),  
  selectedItemColor: Color(0xFFB2F4FF),  
  ),  
  BuildNavigationItem(  
      tooltip: 'Peoples',  
  itemColor: Color(0xFFCDB2FF),  
  icon: Icon(Icons.people),  
  selectedItemColor: Color(0xFFCDB2FF),  
  ),  
  BuildNavigationItem(  
        tooltip: 'Settings',  
  itemColor: Color(0xFFFFB2D9),  
  icon: Icon(Icons.settings),  
  selectedItemColor: Color(0xFFFFB2D9)),  
  ],  
),

Screenshots #

drawing drawing drawing

[0.0.1] - SAT 23 FEB 2019

  • Publish

[0.0.2] - SAT 23 FEB 2019

*Fixed some errors

[0.0.3] - SAT 23 FEB 2019

*Fixed Some Errors and README.MD

[1.0.0] - SAT 16 MARCH 2019

*Fixed Some Errors and And ADDED MIT License

example/README.md

bottom_navigation_by_package #

Getting Started #

1. Add the dependencies to [pubspec.yaml]

dependencies:
	sphere_bottom_navigation_bar: ^1.0.0

2. Install it #

You can install packages from the command line:

$ flutter packages get

3. Import package #

import  'package:sphere_bottom_navigation_bar/sphere_bottom_navigation_bar.dart';

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sphere_bottom_navigation_bar: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sphere_bottom_navigation_bar/sphere_bottom_navigation_bar.dart';
  
Version Uploaded Documentation Archive
1.0.0 Mar 16, 2019 Go to the documentation of sphere_bottom_navigation_bar 1.0.0 Download sphere_bottom_navigation_bar 1.0.0 archive
0.0.3 Feb 23, 2019 Go to the documentation of sphere_bottom_navigation_bar 0.0.3 Download sphere_bottom_navigation_bar 0.0.3 archive
0.0.2 Feb 23, 2019 Go to the documentation of sphere_bottom_navigation_bar 0.0.2 Download sphere_bottom_navigation_bar 0.0.2 archive
0.0.1 Feb 23, 2019 Go to the documentation of sphere_bottom_navigation_bar 0.0.1 Download sphere_bottom_navigation_bar 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
31
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Mar 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.3.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test