spine_core 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

spine_core

The spine_core runtime provides functionality to load and manipulate Spine skeletal animation data using Dart. It does not perform rendering but can be extended to enable Spine animations for other Dart-based projects.

Spine License

This Spine Runtime may only be used for personal or internal use, typically to evaluate Spine before purchasing. If you would like to incorporate a Spine Runtime into your applications, distribute software containing a Spine Runtime, or modify a Spine Runtime, then you will need a valid Spine license. Please see the Spine Runtimes Software License for detailed information.

The Spine Runtimes are developed with the intent to be used with data exported from Spine. By purchasing Spine, Section 2 of the Spine Software License grants the right to create and distribute derivative works of the Spine Runtimes.

0.1.0

  • Initial version, created by Junji Takakura

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  spine_core: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:spine_core/spine_core.dart';
  
Version Uploaded Documentation Archive
0.1.0 Jun 9, 2018 Go to the documentation of spine_core 0.1.0 Download spine_core 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
1
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.51.0 <2.0.0