Sporran is a PouchDB alike implementation for Dart.
It uses Lawndart(browser local storage client) and Wilt(browser CouchDB client) to allow browser based CouchDB users to transition between online and offline modes and carry on working normally.
When the browser is online Sporran acts just like Wilt, i.e is a CouchDB client, but all database transactions are reflected into local storage. If the browser goes offline Sporran switches to using local storage only, when the browser comes back online the local database is synced up with CouchDB, all transparent to the user.
The CouchDB change notification interface is also used to keep Sporran in sync with any 3rd party changes to your CouchDB database.
Please read the documents under the doc folder for usage information, the API is also under this folder and is available here
Queries you can direct to me at email@example.com or raise an issue here.
Update to new Wilt + JsonObjectLite, remove analysis errors
Updates ready for Dart 2, remove the completion interface.
Updates for issues 7, 5, 6, 8 and 4 Note that issue 4 changes how Sporran is constructed and is thus breaking.
Updates for DartV1.5.3, all tests running
Issues 1 and 2, Sporran now has a futures based API
Add this to your package's pubspec.yaml file:
dependencies: sporran: ^3.1.0
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|3.1.0||Dec 15, 2017|
|3.0.0||Sep 12, 2017|
|2.1.0||Sep 17, 2014|
|2.0.0||Mar 13, 2014|
|1.0.0||Mar 3, 2014|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
|Dart SDK||>=1.8.0 <2.0.0|