spotify 0.0.7

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 30

spotify-dart Pub Build Status

A dart library for interfacing with the Spotify API.

Usage

A simple usage example:

import 'package:spotify/spotify_io.dart';

main() async {
  var credentials = new SpotifyApiCredentials(clientId, clientSecret);
  var spotify = new SpotifyApi(credentials);

  var artist = await spotify.artists.get('0OdUWJ0sBjDrqHygGUXeCF');
}

For usage in the browser use

import 'package:spotify/spotify_browser.dart';

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.7

  • add user's saved tracks endpoints

0.0.6

  • add pagination support

0.0.5

  • add user and playlist endpoints

0.0.4

  • fix typo in artists endpoint
  • add basic unit tests

0.0.3

  • add support for albums and artists
  • refactor code a little

0.0.1

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  spotify: ^0.0.7

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:spotify/spotify_browser.dart';
import 'package:spotify/spotify_browser.json.g.dart';
import 'package:spotify/spotify_io.dart';
import 'package:spotify/spotify_io.json.g.dart';
  
Version Uploaded Documentation Archive
0.0.7 Feb 10, 2018 Go to the documentation of spotify 0.0.7 Download spotify 0.0.7 archive
0.0.6 Oct 15, 2017 Go to the documentation of spotify 0.0.6 Download spotify 0.0.6 archive
0.0.5 Oct 14, 2017 Go to the documentation of spotify 0.0.5 Download spotify 0.0.5 archive
0.0.4 Oct 12, 2017 Go to the documentation of spotify 0.0.4 Download spotify 0.0.4 archive
0.0.3 Aug 13, 2017 Go to the documentation of spotify 0.0.3 Download spotify 0.0.3 archive
0.0.2 Aug 12, 2017 Go to the documentation of spotify 0.0.2 Download spotify 0.0.2 archive
0.0.1 Aug 12, 2017 Go to the documentation of spotify 0.0.1 Download spotify 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
60
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
30
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0