spotify_playback 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new44

spotify_playback

Spotify Playback Plugin.

Getting Started

Features

  • Play track/album/playlist
  • Play/pause
  • Playback position

Installation

First, add spotify_playback as a dependency in your pubspec.yaml file.

Then initialize the spotify playback sdk like this

@override
  void initState() {
    super.initState();
    initConnector();
  }

  /// Initialize the spotify playback sdk, by calling spotifyConnect
  Future<void> initConnector() async {
    try {
      await SpotifyPlayback.spotifyConnect(clientId: "", redirectUrl: "").then(
          (connected) {
        if (!mounted) return;
        // If the method call is successful, update the state to reflect this change
        setState(() {
          _connectedToSpotify = connected;
        });
      }, onError: (error) {
        // If the method call trows an error, print the error to see what went wrong
        print(error);
      });
    } on PlatformException {
      print('Failed to connect.');
    }
  }

After this you can use all the available methods

Available methods

Methoddescriptionparameters
spotifyConnectInitilizes the spotify playback sdkclientId, redirectUrl
playPlay's an spotify track, album or playlistspotify uri
pausePause's the currently playing track
resumeResumes the currently paused track
getPlaybackPositionGet's the current tracks playback position

Example

Demonstrates how to use the spotify_playback plugin.

See the example documentation for more information.

Changelog

See CHANGELOG.md.

Contributing

Feel free to contribute by opening issues and/or pull requests. Your feedback is very welcome!

License

MIT License

Copyright (c) [2019] [Joran Dob]

0.0.1

  • TODO: Describe initial release.

example/README.md

spotify_playback_example

Demonstrates how to use the spotify_playback plugin.

The example app has an basic implementation to connect to:

  • Play an predefined track
  • Pause the currently playing track on your account
  • Resume the currently paused track on your account
  • Stop the playback for the current track
  • Get the current position of the active track
  • Get track information for the current track

Getting Started

The only thing needed to use this example app is an registerd apllication.

Please add an new app here, https://developer.spotify.com/dashboard/applications

And register the Android app, with this application id io.feesie.spotify.playback.example and your development signing cert SHA1 fingerprint

For an more detailed guide to do this, go here: https://developer.spotify.com/documentation/general/guides/app-settings/

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  spotify_playback: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:spotify_playback/spotify_playback.dart';
  
Version Uploaded Documentation Archive
0.0.2 Jan 12, 2019 Go to the documentation of spotify_playback 0.0.2 Download spotify_playback 0.0.2 archive
0.0.1 Jan 9, 2019 Go to the documentation of spotify_playback 0.0.1 Download spotify_playback 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8