sqlite 0.4.2

  • README.md
  • Installing
  • Versions
  • 76

SQLite bindings for the Dart VM

Build status


Add the library to your specs:

  sqlite: ^0.3.0


See the examples for how to use the library and the pub.dartlang.org page for the API documentation.

Copyright 2012 Google Inc.

Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.


  • Dynamic getters
  • Working examples
  • New async-friendly API


  • Updated to run on Dart 1.15.0
  • Removed Windows support
  • Package publication support


  • Even better stuff


  • Genesis of the good stuff

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  sqlite: "^0.4.2"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:sqlite/sqlite.dart';
Version Uploaded Documentation Archive
0.4.2 Oct 23, 2016 Go to the documentation of sqlite 0.4.2 Download sqlite 0.4.2 archive
0.4.1 Oct 23, 2016 Go to the documentation of sqlite 0.4.1 Download sqlite 0.4.1 archive
0.4.0 Apr 26, 2016 Go to the documentation of sqlite 0.4.0 Download sqlite 0.4.0 archive
0.3.0 Apr 11, 2016 Go to the documentation of sqlite 0.3.0 Download sqlite 0.3.0 archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
79 / 100
Code health derived from static analysis. [more]
99 / 100
Reflects how tidy and up-to-date the package is. [more]
34 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: other

Primary library: package:sqlite/sqlite.dart with components: nativewrappers, mirrors.


  • Package is getting outdated.

    The package was released 86 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 hints.

    Strong-mode analysis of lib/src/request.dart gave the following hint:

    line: 83 col: 34
    'ZERO' is deprecated and shouldn't be used.

    Strong-mode analysis of lib/src/row.dart gave the following hint:

    line: 13 col: 2
    'proxy' is deprecated and shouldn't be used.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use sqlite.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

  • Enable strong mode analysis.

    Strong mode helps you to detect bugs and potential issues earlier.Start your analysis_options.yaml file with the following:

      strong-mode: true


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.3 <2.0.0
args ^0.13.4 0.13.7 1.4.3
http ^0.11.3+3 0.11.3+16
path ^1.3.9 1.6.1
yaml ^2.1.8 2.1.14
Transitive dependencies
async 2.0.7
charcode 1.1.1
collection 1.14.10
http_parser 3.1.2
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
Dev dependencies
test ^0.12.13