sqlite2 0.5.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 62

SQLite bindings for the Dart VM

Build status

Installation

Add the library to your specs:

dependencies:
  sqlite: ^0.5.0

Documentation

See the examples for how to use the library and the pub.dartlang.org page for the API documentation.

0.5.0

  • Adapted lib to Dart 2.0
  • Removed deprecated code

0.4.0

  • Dynamic getters
  • Working examples
  • New async-friendly API

0.3.0

  • Updated to run on Dart 1.15.0
  • Removed Windows support
  • Package publication support

0.2

  • Even better stuff

0.1

  • Genesis of the good stuff

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sqlite2: ^0.5.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sqlite2/sqlite.dart';
  
Version Uploaded Documentation Archive
0.5.1 Oct 10, 2018 Go to the documentation of sqlite2 0.5.1 Download sqlite2 0.5.1 archive
0.5.0 Oct 10, 2018 Go to the documentation of sqlite2 0.5.0 Download sqlite2 0.5.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
52
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
62
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: other

Platform components identified in package: nativewrappers.

Maintenance issues and suggestions

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 3 dependencies without version constraints. Specify version ranges for the following dependencies: http, path, yaml.

Homepage does not exists. (-20 points)

We were unable to access https://github.com/l7ssha/dart-sqlite at the time of the analysis.

Use analysis_options.yaml. (-10 points)

Rename old .analysis_options file to analysis_options.yaml.

Read more about the setup of analysis-options.yaml.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use sqlite2.dart. Packages with multiple examples should use example/readme.md.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.3 <3.0.0
http any 0.12.0
path any 1.6.2
yaml any 2.1.15
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6
source_span 1.4.1
string_scanner 1.0.4
typed_data 1.1.6
Dev dependencies
test any