Add the library to your specs:
dependencies: sqlite: ^0.5.0
Add this to your package's pubspec.yaml file:
dependencies: sqlite2: ^0.5.1
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.5.1||Oct 10, 2018|
|0.5.0||Oct 10, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: other
Platform components identified in package:
Use constrained dependencies. (-20 points)
pubspec.yaml contains 3 dependencies without version constraints. Specify version ranges for the following dependencies:
Homepage does not exists. (-20 points)
We were unable to access
https://github.com/l7ssha/dart-sqlite at the time of the analysis.
analysis_options.yaml. (-10 points)
.analysis_options file to
The description is too short. (-20 points)
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Maintain an example.
None of the files in your
example/ directory matches a known example patterns. Common file name patterns include:
example.dart or you could also use
sqlite2.dart. Packages with multiple examples should use
|Dart SDK||>=1.8.3 <3.0.0|