sqlite_latest 0.5.1+2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 17

SQLite bindings for the Dart VM #

Build status

Installation #

Add the library to your specs:

dependencies:
  sqlite: ^0.3.0

Documentation #

See the examples for how to use the library and the pub.dartlang.org page for the API documentation.

Copyright 2012 Google Inc.

Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

0.5.0 #

  • Update to Dart 2.0

0.4.0 #

  • Dynamic getters
  • Working examples
  • New async-friendly API

0.3.0 #

  • Updated to run on Dart 1.15.0
  • Removed Windows support
  • Package publication support

0.2 #

  • Even better stuff

0.1 #

  • Genesis of the good stuff

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sqlite_latest: ^0.5.1+2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sqlite_latest/sqlite.dart';
  
Version Uploaded Documentation Archive
0.5.1+2 Jan 18, 2019 Go to the documentation of sqlite_latest 0.5.1+2 Download sqlite_latest 0.5.1+2 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
34
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
17
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.3 <=3.0.0