sqltree 0.6.0

  • Installing
  • Versions
  • 43

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sqltree: "^0.6.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sqltree/sqltree.dart';
        
Version Uploaded Documentation Archive
0.6.0 Dec 13, 2016 Go to the documentation of sqltree 0.6.0 Download sqltree 0.6.0 archive
0.5.0 Dec 6, 2016 Go to the documentation of sqltree 0.5.0 Download sqltree 0.5.0 archive
0.4.0 Dec 6, 2016 Go to the documentation of sqltree 0.4.0 Download sqltree 0.4.0 archive
0.3.0 Jul 20, 2016 Go to the documentation of sqltree 0.3.0 Download sqltree 0.3.0 archive
0.2.0 Jul 11, 2016 Go to the documentation of sqltree 0.2.0 Download sqltree 0.2.0 archive
0.1.0 Jun 21, 2016 Go to the documentation of sqltree 0.1.0 Download sqltree 0.1.0 archive
0.0.1+1 Jun 14, 2016 Go to the documentation of sqltree 0.0.1+1 Download sqltree 0.0.1+1 archive
0.0.1 Jun 14, 2016 Go to the documentation of sqltree 0.0.1 Download sqltree 0.0.1 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
65 / 100
Overall score:
Weighted score of the above. [more]
43

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:sqltree/sqltree.dart.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Maintain README.md.

    Readme should inform others about your project, what it does, and how they can use it.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
collection ^1.8.0 1.14.5
Dev dependencies
test >=0.12.0 <0.13.0