sqltree_query 0.5.0+1

  • Installing
  • Versions
  • 0

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sqltree_query: ^0.5.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sqltree_query/sqltree_query.dart';
  
Version Uploaded Documentation Archive
0.5.0+1 Dec 13, 2016 Go to the documentation of sqltree_query 0.5.0+1 Download sqltree_query 0.5.0+1 archive
0.5.0 Dec 13, 2016 Go to the documentation of sqltree_query 0.5.0 Download sqltree_query 0.5.0 archive
0.4.0 Dec 6, 2016 Go to the documentation of sqltree_query 0.4.0 Download sqltree_query 0.4.0 archive
0.3.0+2 Nov 30, 2016 Go to the documentation of sqltree_query 0.3.0+2 Download sqltree_query 0.3.0+2 archive
0.3.0+1 Oct 13, 2016 Go to the documentation of sqltree_query 0.3.0+1 Download sqltree_query 0.3.0+1 archive
0.3.0 Jul 29, 2016 Go to the documentation of sqltree_query 0.3.0 Download sqltree_query 0.3.0 archive
0.2.0 Jul 20, 2016 Go to the documentation of sqltree_query 0.2.0 Download sqltree_query 0.2.0 archive
0.1.0 Jul 11, 2016 Go to the documentation of sqltree_query 0.1.0 Download sqltree_query 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0