square_calendar 0.1.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 20

square_calendar

A widget plugin for showing calendar.

Getting Started

import

import 'package:square_calendar/square_calendar.dart';

just show calendar

new SquareCalendar(year: 2018, month: 2),

change gesture behavior

see example repo to get example

images

simulator screen shot - iphone x - 2018-03-20 at 16 26 58

Changelog

All notable changes to this project will be documented in this file.

The format is based on Keep a Changelog and this project adheres to Semantic Versioning.

[0.1.1] - 2018-03-28

Changed

  • flutter sdk version

[0.1.0] - 2018-03-28

Changed

  • Fixed a bug unnecessary row has displayed when start from friday and finish 30th.

[0.0.9] - 2018-03-28

Changed

  • Fixed a bug unnecessary row has displayed when start from sunday

[0.0.8] - 2018-03-28

Changed and deleted

  • To make builders to be undisputed, made builder to be a widget builder or a nested widget builder, and deletede gesture builder and rowtile builder.

[0.0.7] - 2018-03-27

Changed

  • Return type of tilebuilder to Widget

[0.0.6] - 2018-03-27

Removed

  • unnecessary process line

[0.0.5] - 2018-03-21

Added

  • hasHeader parameter not to display

[0.0.4] - 2018-03-21

Added

  • CHANGELOG.md
  • CalendarWidgetBuilder

Removed

  • Unused Parameter

[0.0.3] - 2018-03-21

Added

  • make CalendarGridGestureDetectorBuilder to receive displayed date.

[0.0.2] - 2018-03-21

Added

  • CODE_OF_CONDUCT.md
  • CONTRIBUTING.md
  • ISSUE_TEMPLATE.md
  • PULL_REQUEST_TEMPLATE.md

Removed

  • Examples

[0.0.1] - 2018-03-20

Added

  • LICENSE
  • CalendarGridTileBuilder
  • CalendarGridGestureDetectorBuilder
  • SquareCalendar
  • Examples

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  square_calendar: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:square_calendar/square_calendar.dart';
  
Version Uploaded Documentation Archive
0.1.1 Mar 28, 2018 Go to the documentation of square_calendar 0.1.1 Download square_calendar 0.1.1 archive
0.1.0 Mar 27, 2018 Go to the documentation of square_calendar 0.1.0 Download square_calendar 0.1.0 archive
0.0.9 Mar 27, 2018 Go to the documentation of square_calendar 0.0.9 Download square_calendar 0.0.9 archive
0.0.8 Mar 27, 2018 Go to the documentation of square_calendar 0.0.8 Download square_calendar 0.0.8 archive
0.0.7 Mar 26, 2018 Go to the documentation of square_calendar 0.0.7 Download square_calendar 0.0.7 archive
0.0.6 Mar 26, 2018 Go to the documentation of square_calendar 0.0.6 Download square_calendar 0.0.6 archive
0.0.5 Mar 21, 2018 Go to the documentation of square_calendar 0.0.5 Download square_calendar 0.0.5 archive
0.0.4 Mar 21, 2018 Go to the documentation of square_calendar 0.0.4 Download square_calendar 0.0.4 archive
0.0.3 Mar 21, 2018 Go to the documentation of square_calendar 0.0.3 Download square_calendar 0.0.3 archive
0.0.2 Mar 21, 2018 Go to the documentation of square_calendar 0.0.2 Download square_calendar 0.0.2 archive

All 11 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
40
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
20
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0