sse 2.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 64

This package provides support for bi-directional communication through Server Sent Events and corresponding POST requests.

2.0.1 #

  • Update to package:uuid version 2.0.

2.0.0 #

  • No longer expose close and onClose on an SseConnection. This is simply handled by the underlying stream / sink.
  • Fix a bug where resources of the SseConnection were not properly closed.

1.0.0 #

  • Internal cleanup.

0.0.1 #

  • Initial commit.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sse: ^2.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sse/client/sse_client.dart';
import 'package:sse/server/sse_handler.dart';
  
Version Uploaded Documentation Archive
2.0.1 Mar 20, 2019 Go to the documentation of sse 2.0.1 Download sse 2.0.1 archive
2.0.0 Mar 11, 2019 Go to the documentation of sse 2.0.0 Download sse 2.0.0 archive
1.0.0 Feb 15, 2019 Go to the documentation of sse 1.0.0 Download sse 1.0.0 archive
0.0.1 Feb 5, 2019 Go to the documentation of sse 0.0.1 Download sse 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
50
Health:
Code health derived from static analysis. [more]
75
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
64
Learn more about scoring.

We analyzed this package on Apr 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms:

Conflicting libraries: package:sse/client/sse_client.dart (components: html, isolate).

Health issues and suggestions

Fix platform conflict in lib/client/sse_client.dart. (-25 points)

Make sure that the imported libraries are not in conflict. Detected components: html, isolate.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Conflicting libraries: package:sse/client/sse_client.dart (components: html, isolate).

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and sse.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.64.1 <3.0.0
async ^2.0.8 2.2.0
http ^0.12.0+1 0.12.0+2
logging ^0.11.3+2 0.11.3+2
pedantic ^1.4.0 1.5.0
shelf ^0.7.4 0.7.5
stream_channel ^1.6.8 1.7.0 2.0.0
uuid ^2.0.0 2.0.1
Transitive dependencies
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
http_parser 3.1.3
meta 1.1.7
path 1.6.2
source_span 1.5.5
stack_trace 1.9.3
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
shelf_static ^0.2.8
test ^1.5.3
webdriver ^2.0.0