stagexl_bitmapfont 0.4.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 73

The StageXL BitmapFont library is an extension to the StageXL library and provides support for bitmap fonts.

Build Status

Bitmap Fonts

Bitmap fonts can be created with different tools, here is just a short list of the most popular tools available:

bmGlyph http://www.bmglyph.com/screenshots (Mac)
Glyph Designer https://71squared.com/glyphdesigner (Mac and Windows)
BMFont http://www.angelcode.com/products/bmfont (Windows)
Littera http://kvazars.com/littera (Online)

Examples

http://www.stagexl.org/show/bitmapfont/simple/example.html
http://www.stagexl.org/show/bitmapfont/texture_atlas/example.html
http://www.stagexl.org/show/bitmapfont/tinting/example.html
http://www.stagexl.org/show/bitmapfont/distance_field/example.html

StageXL

The StageXL library is intended for Flash developers who want to migrate their projects as well as their skills to HTML5. Therefore the library provides the familiar Flash API built on open web standards.

changelog

This file contains highlights of what changes on each version of the StageXL_BitmapFont package. This file is normally updated whenever we push a new version to pub.

Pub version 0.4.0

  • Added support for HiDpi BitmapFonts.
  • Enables Dart Strong Mode.
  • Raised dependency to StageXL 1.3.0

Pub version 0.3.1

  • Raised dependency to StageXL 1.0.0

Pub version 0.3.0

  • Added DistanceFieldShadowFilter
  • Changed DistanceFieldConfig

Pub version 0.2.0

  • BitmapText extends Bitmap and therefore renders super fast.
  • BitmapContainerText extends DisplayObjectContainer and is super flexible.
  • Added DistanceFieldFilters for vector like scaling.

Pub version 0.1.1

  • Updated to StageXL 0.13.0

Pub version 0.1.0

  • Support for Bitmap Font formats: FNT, JSON, XML
  • Support loaders for File BitmapData and TextureAtlas
  • BitmapFont class to query character properties.
  • BitmapText display object to draw text on the stage.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  stagexl_bitmapfont: "^0.4.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:stagexl_bitmapfont/stagexl_bitmapfont.dart';
        
Version Uploaded Documentation Archive
0.4.0 Aug 26, 2017 Go to the documentation of stagexl_bitmapfont 0.4.0 Download stagexl_bitmapfont 0.4.0 archive
0.3.1 Dec 3, 2016 Go to the documentation of stagexl_bitmapfont 0.3.1 Download stagexl_bitmapfont 0.3.1 archive
0.3.0 Sep 24, 2016 Go to the documentation of stagexl_bitmapfont 0.3.0 Download stagexl_bitmapfont 0.3.0 archive
0.2.0+1 Jul 23, 2016 Go to the documentation of stagexl_bitmapfont 0.2.0+1 Download stagexl_bitmapfont 0.2.0+1 archive
0.2.0 Jul 23, 2016 Go to the documentation of stagexl_bitmapfont 0.2.0 Download stagexl_bitmapfont 0.2.0 archive
0.1.1 Nov 21, 2015 Go to the documentation of stagexl_bitmapfont 0.1.1 Download stagexl_bitmapfont 0.1.1 archive
0.1.0 Jun 22, 2015 Go to the documentation of stagexl_bitmapfont 0.1.0 Download stagexl_bitmapfont 0.1.0 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
49 / 100
Health:
Code health derived from static analysis. [more]
98 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
95 / 100
Overall score:
Weighted score of the above. [more]
73

Platforms

Detected platforms: web

Primary library: package:stagexl_bitmapfont/stagexl_bitmapfont.dart with components: html.

Suggestions

  • Use constrained dependencies.

    The pubspec.yaml contains 2 dependencies without version constraints. Specify version ranges for the following dependencies: browser, xml.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use stagexl_bitmapfont.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.0 <2.0.0
browser any 0.10.0+2
stagexl ^1.3.0 1.3.0+1
xml any 2.6.0 3.0.0-alpha
Transitive dependencies
matcher 0.12.1+4
path 1.5.1
petitparser 1.7.0
stack_trace 1.9.1