stagexl_gaf 0.1.4+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 84

StageXL_GAF

The GAF runtime for the StageXL library.

Use the GAF converter to convert Adobe Flash animations to the GAF-format,
learn more about it here: http://gafmedia.com/

Best solution to improve your workflow

  • GAF greatly reduces the number of steps in game development workflow.
  • Play any Flash 2D animation (explosions, cutscenes, characters, etc).
  • No special pre-preparation needed to convert your Flash 2D animations.

High performance even on low-end hardware

  • High FPS by pre-rendering vector assets to texture atlases.
  • Minimized draw-calls by using StageXLs rendering API.
  • Built in support for HiDPI displays and textures.

##Examples

Skeleton (http://www.stagexl.org/show/gaf/skeleton/example.html)
Slot Machine (http://www.stagexl.org/show/gaf/slot_machine/example.html)
Ufo Monster (http://www.stagexl.org/show/gaf/ufo_monster/example.html)
Named Parts (http://www.stagexl.org/show/gaf/named_parts/example.html)
Sequences (http://www.stagexl.org/show/gaf/sequences/example.html)
Gun Swap (http://www.stagexl.org/show/gaf/gun_swap/example.html)
Fireman (http://www.stagexl.org/show/gaf/fireman/example.html)
Rocket (http://www.stagexl.org/show/gaf/rocket/example.html)
Sound (http://www.stagexl.org/show/gaf/sound/example.html)

##License

The GAF runtime for StageXL is based on the official AS3 runtime.
The source code was greatly refactored for best performance and simplicity.

https://github.com/CatalystApps/StarlingGAFPlayer

Change Log

This file contains highlights of what changes on each version of the StageXL_GAF package. This file is normally updated whenever we push a new version to pub.

Pub version 0.1.4

  • Added support for strong mode
  • Raised dependency to Dart SDK 1.22.0 (reason: covariant keyword)

Pub version 0.1.3

  • Raised dependency to StageXL 1.0.0

Pub version 0.1.2

  • Added support for GAF bundles in ZIP files

Pub version 0.1.1

  • Fixed multi texture assets

Pub version 0.1.0

  • Port of the official AS3/Starling runtime
  • Major refactoring and changes

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  stagexl_gaf: "^0.1.4+1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:stagexl_gaf/stagexl_gaf.dart';
        
Version Uploaded Documentation Archive
0.1.4+1 Jun 27, 2017 Go to the documentation of stagexl_gaf 0.1.4+1 Download stagexl_gaf 0.1.4+1 archive
0.1.4 Jun 27, 2017 Go to the documentation of stagexl_gaf 0.1.4 Download stagexl_gaf 0.1.4 archive
0.1.3 Dec 3, 2016 Go to the documentation of stagexl_gaf 0.1.3 Download stagexl_gaf 0.1.3 archive
0.1.2+3 Jun 11, 2016 Go to the documentation of stagexl_gaf 0.1.2+3 Download stagexl_gaf 0.1.2+3 archive
0.1.2+2 Jun 10, 2016 Go to the documentation of stagexl_gaf 0.1.2+2 Download stagexl_gaf 0.1.2+2 archive
0.1.2+1 Jun 10, 2016 Go to the documentation of stagexl_gaf 0.1.2+1 Download stagexl_gaf 0.1.2+1 archive
0.1.2 Jun 10, 2016 Go to the documentation of stagexl_gaf 0.1.2 Download stagexl_gaf 0.1.2 archive
0.1.1 Mar 22, 2016 Go to the documentation of stagexl_gaf 0.1.1 Download stagexl_gaf 0.1.1 archive
0.1.0 Mar 18, 2016 Go to the documentation of stagexl_gaf 0.1.0 Download stagexl_gaf 0.1.0 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
70 / 100
Health:
Code health derived from static analysis. [more]
98 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
95 / 100
Overall score:
Weighted score of the above. [more]
84

Platforms

Detected platforms: web

Primary library: package:stagexl_gaf/stagexl_gaf.dart with components: html.

Suggestions

  • Use constrained dependencies.

    The pubspec.yaml contains 2 dependencies without version constraints. Specify version ranges for the following dependencies: archive, browser.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use stagexl_gaf.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.22.0 <2.0.0
archive any 1.0.33
browser any 0.10.0+2
stagexl ^1.0.0 1.3.0+1
Transitive dependencies
args 1.3.0
charcode 1.1.1
collection 1.14.5
convert 2.0.1
crypto 2.0.2+1
matcher 0.12.1+4
path 1.5.1
petitparser 1.7.0
stack_trace 1.9.1
typed_data 1.1.5
xml 2.6.0 3.0.0-alpha