stagexl_toolkit 0.1.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 19

StageXL_Toolkit

The 'Toolkit for Dart' runtime for the StageXL library.

Build Status

##Toolkit for Dart

http://toolkitfordart.github.io/

The Toolkit for Dart is an extension to Flash Professional CC to publish artwork and animation to the Dart language, which is a class-based, object-oriented language and compiles to efficient JavaScript that is being developed as open source by Google. The extension creates a fully functional and cleanly organized Dart project, leveraging the StageXL for Dart library to reproduce Flash runtime features.

Toolkit for Dart supports many of the core animation and drawing capabilities of Flash Pro, including bitmaps, shapes, movie clips, graphic symbols, classic tweens and motion guides, simple buttons, text fields, drop-shadow and glow filters, additive blend mode, single-shape masks, visible and cacheAsBitmap display options, and embedded audio.

##Examples

TODO

changelog

This file contains highlights of what changes on each version of the StageXL_Toolkit package. This file is normally updated whenever we push a new version to pub.

Pub version 0.1.0

  • Raised dependency to StageXL 1.0.0

Pub version 0.1.0

  • Create a dedicated 'Toolkit for Dart' package.
  • Removed the 'Toolkit for Dart' related code from StageXL.
  • Initial commit.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  stagexl_toolkit: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:stagexl_toolkit/stagexl_toolkit.dart';
  
Version Uploaded Documentation Archive
0.1.1 Dec 3, 2016 Go to the documentation of stagexl_toolkit 0.1.1 Download stagexl_toolkit 0.1.1 archive
0.1.0 Feb 20, 2016 Go to the documentation of stagexl_toolkit 0.1.0 Download stagexl_toolkit 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
38
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
19
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.0 <2.0.0