static_dom 0.1.1

  • Example
  • Installing
  • Versions
  • 0

static_dom #

A simple static HTML DOM builder library for Dart

Usage #

A simple usage example:

Future updatePics() async {
  final JsonResponse resp = await client.getJson('/api/pics');
  List<String> body = resp.body;
  Div divEl = div().forEach<String>(
      (String text) => div(classes: ['item'])
        ..add(img('/data/img/$text', classes: ["item-img"]))
        ..add(t(text, classes: ["item-txt"])));

Changelog #

0.1.1 #

  • Added Pre element

0.1.0 #

  • Removed events
  • Added more components
  • New style and CSS system

0.0.2 #

  • Checkbox input element

0.0.1 #

  • Basic elements: Div, Text, Image
  • ItemMaker for children


// Copyright (c) 2017, teja. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:static_dom/static_dom.dart';

main() {
  final data = <String>['messi.jpg', 'neymar.jpg'];
  Div divEl = div().forEach<String>(
      (String text) => div(classes: ['item'])
        ..add(img('/data/img/$text', classes: ["item-img"]))
        ..add(t(text, classes: ["item-txt"])));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  static_dom: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:static_dom/static_dom.dart';
Version Uploaded Documentation Archive
0.1.1 Aug 22, 2017 Go to the documentation of static_dom 0.1.1 Download static_dom 0.1.1 archive
0.1.0 Aug 16, 2017 Go to the documentation of static_dom 0.1.0 Download static_dom 0.1.0 archive
0.0.3 Jul 20, 2017 Go to the documentation of static_dom 0.0.3 Download static_dom 0.0.3 archive
0.0.1 Jun 9, 2017 Go to the documentation of static_dom 0.0.1 Download static_dom 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0