static_dom 0.1.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

static_dom

A simple static HTML DOM builder library for Dart

Usage

A simple usage example:

Future updatePics() async {
  final JsonResponse resp = await client.getJson('/api/pics');
  print(resp.body);
  List<String> body = resp.body;
  Div divEl = div().forEach<String>(
      data,
      (String text) => div(classes: ['item'])
        ..add(img('/data/img/$text', classes: ["item-img"]))
        ..add(t(text, classes: ["item-txt"])));
  print(div.render());
  picHolder.setInnerHtml(div.render());
}

Changelog

0.1.1

  • Added Pre element

0.1.0

  • Removed events
  • Added more components
  • New style and CSS system

0.0.2

  • Checkbox input element

0.0.1

  • Basic elements: Div, Text, Image
  • ItemMaker for children

example/static_dom_example.dart

// Copyright (c) 2017, teja. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:static_dom/static_dom.dart';

main() {
  final data = <String>['messi.jpg', 'neymar.jpg'];
  Div divEl = div().forEach<String>(
      data,
      (String text) => div(classes: ['item'])
        ..add(img('/data/img/$text', classes: ["item-img"]))
        ..add(t(text, classes: ["item-txt"])));
  print(divEl.render());
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  static_dom: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:static_dom/static_dom.dart';
  
Version Uploaded Documentation Archive
0.1.1 Aug 22, 2017 Go to the documentation of static_dom 0.1.1 Download static_dom 0.1.1 archive
0.1.0 Aug 16, 2017 Go to the documentation of static_dom 0.1.0 Download static_dom 0.1.0 archive
0.0.3 Jul 20, 2017 Go to the documentation of static_dom 0.0.3 Download static_dom 0.0.3 archive
0.0.1 Jun 9, 2017 Go to the documentation of static_dom 0.0.1 Download static_dom 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0