stomp 0.7.3

  • README.md
  • Installing
  • Versions
  • 57

#STOMP Dart Client

STOMP Dart client for communicating with STOMP complaint messaging brokers and servers.

Stomp Dart Client is distributed under an Apache 2.0 License.

Build Status

See also Ripple - Lightweight Dart Messaging Server.

##Installation

Add this to your pubspec.yaml (or create it):

dependencies:
  stomp:

Then run the Pub Package Manager (comes with the Dart SDK):

pub install

##Usage

###Running on Dart VM

import "package:stomp/stomp.dart";
import "package:stomp/vm.dart" show connect;

void main() {
  connect("foo.server.com").then((StompClient client) {
    client.subscribeString("/foo",
      (Map<String, String> headers, String message) {
        print("Recieve $message");
      });

    client.sendString("/foo", "Hi, Stomp");
  });
}

There are basically a few alternative ways to communicate:

  • JSON objects: sendJson() and subscribeJson()
  • Strings: sendString() and subscribeString()
  • Bytes: sendBytes() and subscribeBytes()
  • BLOB (huge data): sendBlob() and subscribeBlob()

Please refer to StompClient for more information.

###Running on Browser

The same as the above, except import websocket.dart instead of vm.dart:

import "package:stomp/stomp.dart";
import "package:stomp/websocket.dart" show connect;

//the rest is the same as running on Dart VM

##Limitations

  • Support STOMP 1.2 or above
  • Support UTF-8 encoding

##Incompleteness

  • Heart beat not supported.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  stomp: "^0.7.3"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:stomp/stomp.dart';
  
Version Uploaded Documentation Archive
0.7.3 Oct 31, 2014 Go to the documentation of stomp 0.7.3 Download stomp 0.7.3 archive
0.7.2 Apr 2, 2014 Go to the documentation of stomp 0.7.2 Download stomp 0.7.2 archive
0.7.1 Feb 14, 2014 Go to the documentation of stomp 0.7.1 Download stomp 0.7.1 archive
0.7.0 Jan 29, 2014 Go to the documentation of stomp 0.7.0 Download stomp 0.7.0 archive
0.6.0+1 Jan 10, 2014 Go to the documentation of stomp 0.6.0+1 Download stomp 0.6.0+1 archive
0.6.0 Dec 21, 2013 Go to the documentation of stomp 0.6.0 Download stomp 0.6.0 archive
0.5.5 Nov 11, 2013 Go to the documentation of stomp 0.5.5 Download stomp 0.5.5 archive
0.5.4 Nov 5, 2013 Go to the documentation of stomp 0.5.4 Download stomp 0.5.4 archive
0.5.3 Oct 29, 2013 Go to the documentation of stomp 0.5.3 Download stomp 0.5.3 archive
0.5.2+1 Aug 27, 2013 Go to the documentation of stomp 0.5.2+1 Download stomp 0.5.2+1 archive

All 13 versions...

Analysis

We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
56 / 100
Health:
Code health derived from static analysis. [more]
97 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
57
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:stomp/stomp.dart.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Use constrained dependencies.

    The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: quiver.

  • Package is too old.

    The package was released more than two years ago.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 30 hints.

    Run dartfmt to format lib/impl/plugin.dart.

    Run dartfmt to format lib/impl/plugin_vm.dart.

    Similar analysis of the following files failed:

    • lib/impl/util.dart (hint)
    • lib/src/impl/util_read.dart (hint)
    • lib/src/impl/util_write.dart (hint)
    • lib/src/stomp_impl.dart (hint)
    • lib/src/stomp_util.dart (hint)
    • lib/stomp.dart (hint)
    • lib/vm.dart (hint)
    • lib/websocket.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use stomp.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0
quiver any 0.29.0+1
Transitive dependencies
matcher 0.12.3
meta 1.1.5
path 1.6.1
stack_trace 1.9.2
Dev dependencies
unittest any