stomp_sockjs 0.2.0

  • Installing
  • Versions
  • 21

Stomp Sockjs client

This is a Dart client library for STOMP over SockJS.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  stomp_sockjs: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:stomp_sockjs/stomp_sockjs.dart';
Version Uploaded Documentation Archive
0.2.0 Aug 23, 2017 Go to the documentation of stomp_sockjs 0.2.0 Download stomp_sockjs 0.2.0 archive
0.1.0 Jun 26, 2015 Go to the documentation of stomp_sockjs 0.1.0 Download stomp_sockjs 0.1.0 archive
0.0.1 Jul 22, 2014 Go to the documentation of stomp_sockjs 0.0.1 Download stomp_sockjs 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 21, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.12.4


Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: Git error. Command: git clone --mirror /tmp/pub-cache-dirUUZEVH/git/cache/sockjs-dart-client-705fcd39149ea9ad086f6f58adebabfae3c5092a
 Cloning into bare repository '/tmp/pub-cache-dirUUZEVH/git/cache/sockjs-dart-client-705fcd39149ea9ad086f6f58adebabfae3c5092a'...
 Host key verification failed.
 fatal: Could not read from remote repository.
 Please make sure you have the correct access rights
 and the repository exists.

Health suggestions

Format lib/stomp_sockjs.dart.

Run dartfmt to format lib/stomp_sockjs.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

Add SDK constraint in pubspec.yaml. (-5 points)

For information about setting SDK constraint, please see

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is getting outdated. (-15.89 points)

The package was released 60 weeks ago.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use stomp_sockjs.dart.