stomp_sockjs 0.2.0

  • README.md
  • Installing
  • Versions
  • 6

Stomp Sockjs client #

This is a Dart client library for STOMP over SockJS.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  stomp_sockjs: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:stomp_sockjs/stomp_sockjs.dart';
  
Version Uploaded Documentation Archive
0.2.0 Aug 23, 2017 Go to the documentation of stomp_sockjs 0.2.0 Download stomp_sockjs 0.2.0 archive
0.1.0 Jun 26, 2015 Go to the documentation of stomp_sockjs 0.1.0 Download stomp_sockjs 0.1.0 archive
0.0.1 Jul 22, 2014 Go to the documentation of stomp_sockjs 0.0.1 Download stomp_sockjs 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
13
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
6
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.