store 0.0.3

  • README.md
  • Installing
  • Versions
  • new41

store

Reactive data store for Flutter

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  store: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:store/store.dart';
  
Version Uploaded Documentation Archive
0.0.3 Dec 6, 2018 Go to the documentation of store 0.0.3 Download store 0.0.3 archive
0.0.2 Dec 6, 2018 Go to the documentation of store 0.0.2 Download store 0.0.2 archive
0.0.1 Dec 5, 2018 Go to the documentation of store 0.0.1 Download store 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
26
Health:
Code health derived from static analysis. [more]
75
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
41
Learn more about scoring.

We analyzed this package on Dec 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Fix lib/store.dart. (-25.38 points)

Analysis of lib/store.dart failed with 1 error, 1 hint:

line 165 col 36: 'T' doesn't extend 'StatefulWidget'.

line 19 col 3: The method '_unwatch' isn't used.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use store.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test