stream 1.6.8+3

  • README.md
  • Installing
  • Versions
  • 85

Stream

Stream is a Dart web server supporting request routing, filtering, template engine, WebSocket, MVC design pattern and file-based static resources.

Stream is distributed under an Apache 2.0 License.

Build Status

Installation

Add this to your pubspec.yaml (or create it):

dependencies:
  stream:

Usage

Compile RSP (Rikulo Stream Page) to dart files

There are two ways to compile RSP files into dart files: automatic building with Dart Editor or manual compiling.

RSP is a template technology allowing developers to create dynamically generated web pages based on HTML, XML or other document types (such as this and this). Please refer to here for more information.

Build with Dart Editor

To compile your RSP files automatically, you just need to add a build.dart file in the root directory of your project, with the following content:

import 'package:stream/rspc.dart';
void main(List<String> arguments) {
  build(arguments);
}

With this build.dart script, whenever your RSP is modified, it will be re-compiled.

Compile Manually

To compile a RSP file manually, run rspc (RSP compiler) to compile it into the dart file with command line interface as follows:

tool/rspc.dart your-rsp-file(s)

A dart file is generated for each RSP file you gave.

Or, you can use a Bash program, tool/rspc, to detect any change of RSP files and compile them automatically.

Notes to Contributors

Fork Stream

If you'd like to contribute back to the core, you can fork this repository and send us a pull request, when it is ready.

Please be aware that one of Stream's design goals is to keep the sphere of API as neat and consistency as possible. Strong enhancement always demands greater consensus.

If you are new to Git or GitHub, please read this guide first.

Who Uses

  • Quire - a simple, collaborative, multi-level task management tool.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  stream: "^1.6.8+3"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:stream/stream.dart';
        
Version Uploaded Documentation Archive
1.6.8+3 Jan 19, 2018 Go to the documentation of stream 1.6.8+3 Download stream 1.6.8+3 archive
1.6.8+2 Jul 26, 2017 Go to the documentation of stream 1.6.8+2 Download stream 1.6.8+2 archive
1.6.8 Apr 12, 2017 Go to the documentation of stream 1.6.8 Download stream 1.6.8 archive
1.6.7+1 Apr 11, 2017 Go to the documentation of stream 1.6.7+1 Download stream 1.6.7+1 archive
1.6.7 Mar 23, 2017 Go to the documentation of stream 1.6.7 Download stream 1.6.7 archive
1.6.6+2 Mar 16, 2017 Go to the documentation of stream 1.6.6+2 Download stream 1.6.6+2 archive
1.6.6+1 Feb 23, 2017 Go to the documentation of stream 1.6.6+1 Download stream 1.6.6+1 archive
1.6.6 Feb 23, 2017 Go to the documentation of stream 1.6.6 Download stream 1.6.6 archive
1.6.5 Dec 3, 2016 Go to the documentation of stream 1.6.5 Download stream 1.6.5 archive
1.6.3 Sep 28, 2016 Go to the documentation of stream 1.6.3 Download stream 1.6.3 archive

All 108 versions...

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Jan 21, 2018
  • Dart: 2.0.0-dev.15.0
  • pana: 0.10.0

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
79 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
76 / 100
Overall score:
Weighted score of the above. [more]
85

Platforms

Detected platforms: other

Primary library: package:stream/stream.dart.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Use constrained dependencies.

    The pubspec.yaml contains 3 dependencies without version constraints. Specify version ranges for the following dependencies: args, logging, path.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use stream.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.9.0
args any 1.2.0
logging any 0.11.3+1
path any 1.5.1
rikulo_commons >=2.0.0 <3.0.0 2.3.6
Transitive dependencies
mime 0.9.5