string_editor 1.0.0-dev+2

  • README.md
  • Installing
  • Versions
  • 39

string_editor

Library for editing strings on a character-by-character basis.

Installation

dependencies:
  string_editor: ^1.0.0-dev

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  string_editor: "^1.0.0-dev+2"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:string_editor/string_editor.dart';
        
Version Uploaded Documentation Archive
1.0.0-dev+2 Sep 23, 2016 Go to the documentation of string_editor 1.0.0-dev+2 Download string_editor 1.0.0-dev+2 archive
1.0.0-dev+1 Sep 23, 2016 Go to the documentation of string_editor 1.0.0-dev+1 Download string_editor 1.0.0-dev+1 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
98 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50 / 100
Overall score:
Weighted score of the above. [more]
39

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:string_editor/string_editor.dart.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Package is pre-release.

    Pre-release versions should be used with caution, their API may change in breaking ways.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use string_editor.dart.

Dependencies

Package Constraint Resolved Available
Dev dependencies
test >=0.12.15+6 <0.13.0