stripe_payment 0.0.6

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 90

stripe_payment

A flutter plugin to integrate the stripe plugin for iOS and Android. Currently only adding a credit card as source is implemented.

Usage

To set your publishable key set:

import 'package:stripe_payment/stripe_payment.dart';
StripeSource.setPublishableKey("pk_test");

from somewhere in your code, e.g. your main.dart file.

To open the dialog:

StripeSource.addSource().then((String token) {
    print(token); //your stripe card source token
});

Android

Please be aware that your main activity must extend from FlutterFragmentActivity. Otherwise the Android dialog would've looked very nasty.

TODO

  • [ ] better error handling
  • [ ] internationalization
  • [ ] more stripe library implementations?

[0.0.6] - 16.05.2018

  • Dart 2 fixes

[0.0.5] - 20.03.2018

  • Compatible with Flutter SDK >=0.1.4 <2.0.0"

[0.0.4] - 29.01.2018

  • Initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:stripe_payment/stripe_payment.dart';

void main() {
  runApp(new MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  @override
  initState() {
    super.initState();
    StripeSource.setPublishableKey("pk_test");
    StripeSource.addSource().then((String token) {
      _addSource(token);
    });
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: new Text('Plugin example app'),
        ),
        body: new Center(
          child: new Text('Running on: $_platformVersion\n'),
        ),
      ),
    );
  }

  void _addSource(String token) {

  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  stripe_payment: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:stripe_payment/stripe_payment.dart';
  
Version Uploaded Documentation Archive
0.0.6 May 16, 2018 Go to the documentation of stripe_payment 0.0.6 Download stripe_payment 0.0.6 archive
0.0.5 Mar 20, 2018 Go to the documentation of stripe_payment 0.0.5 Download stripe_payment 0.0.5 archive
0.0.4 Jan 29, 2018 Go to the documentation of stripe_payment 0.0.4 Download stripe_payment 0.0.4 archive
0.0.3 Jan 29, 2018 Go to the documentation of stripe_payment 0.0.3 Download stripe_payment 0.0.3 archive
0.0.2 Jan 29, 2018 Go to the documentation of stripe_payment 0.0.2 Download stripe_payment 0.0.2 archive
0.0.1 Jan 29, 2018 Go to the documentation of stripe_payment 0.0.1 Download stripe_payment 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
84
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
90
Learn more about scoring.

We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4
  • Flutter: 0.9.5

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/stripe_payment.dart. (-0.50 points)

Analysis of lib/stripe_payment.dart reported 1 hint:

line 15 col 15: The value of the field '_publishableKeySet' isn't used.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8