strophe 0.0.5

  • Installing
  • Versions
  • 58

Strophe-dart is a pure Dart library for speaking XMPP via BOSH (XEP 124 and XEP 206) and WebSockets (RFC 7395).

Its primary purpose is to enable mobile-based(flutter),desktop and web-based, real-time XMPP applications.

The book Professional XMPP Programming with JavaScript and jQuery covers Strophe.Js in detail in the context of web applications.


Bosh and all authenticate mechanisms don't work for the moment .

License It is licensed under the MIT license, except for the files sha1.js, base64.js and md5.js, which are licensed as public domain and BSD (see these files for details).

Author & History Strophe.js was originally created by Jack Moffitt. It was originally developed for Chesspark, an online chess community based on XMPP technology. It has been cared for and improved over the years and is currently maintained by many people in the community.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  strophe: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:strophe/strophe.dart';
Version Uploaded Documentation Archive
0.0.5 Aug 17, 2018 Go to the documentation of strophe 0.0.5 Download strophe 0.0.5 archive
0.0.4 Aug 11, 2018 Go to the documentation of strophe 0.0.4 Download strophe 0.0.4 archive
0.0.3 Aug 10, 2018 Go to the documentation of strophe 0.0.3 Download strophe 0.0.3 archive
0.0.2 Aug 10, 2018 Go to the documentation of strophe 0.0.2 Download strophe 0.0.2 archive
0.0.1 Aug 10, 2018 Go to the documentation of strophe 0.0.1 Download strophe 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/bosh.dart. (-0.50 points)

Analysis of lib/src/bosh.dart reported 1 hint:

line 697 col 11: Equality operator == invocation with references of unrelated types.

Fix lib/src/enums.dart. (-0.50 points)

Analysis of lib/src/enums.dart reported 1 hint:

line 2789 col 12: The value of the local variable 'qop' isn't used.

Fix lib/src/plugins/privacy.dart. (-0.50 points)

Analysis of lib/src/plugins/privacy.dart reported 1 hint:

line 23 col 12: The value of the field '_listChangeCallback' isn't used.

Fix lib/src/plugins/roster.dart. (-0.50 points)

Analysis of lib/src/plugins/roster.dart reported 1 hint:

line 163 col 9: Invocation of remove with references of unrelated types.

Fix lib/src/websocket.dart. (-0.50 points)

Analysis of lib/src/websocket.dart reported 1 hint:

line 285 col 68: 'CLOSED' is deprecated and shouldn't be used.

Maintenance issues and suggestions

Support latest stable Dart SDK in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow the latest stable Dart SDK release.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use strophe.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <=2.1.0
flutter 0.0.0
http ^0.11.3+17 0.11.3+17 0.12.0
xml ^3.0.0 3.2.3
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6
path 1.6.2
petitparser 2.0.2
sky_engine 0.0.99
source_span 1.4.1
string_scanner 1.0.4
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies