stuff 0.0.7

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 2

stuff

Some stuff I need in various packages. You can safely ignore this

Changelog

0.0.7

  • fix handling of Option

0.0.6

  • Strong mode stuff

0.0.3

  • Dynamic JSON

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  stuff: ^0.0.7

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:stuff/stuff.dart';
  
Version Uploaded Documentation Archive
0.0.7 Jun 25, 2016 Go to the documentation of stuff 0.0.7 Download stuff 0.0.7 archive
0.0.6 Apr 10, 2016 Go to the documentation of stuff 0.0.6 Download stuff 0.0.6 archive
0.0.5 Mar 25, 2016 Go to the documentation of stuff 0.0.5 Download stuff 0.0.5 archive
0.0.4 Jan 21, 2016 Go to the documentation of stuff 0.0.4 Download stuff 0.0.4 archive
0.0.3 Jan 6, 2016 Go to the documentation of stuff 0.0.3 Download stuff 0.0.3 archive
0.0.1 Aug 12, 2015 Go to the documentation of stuff 0.0.1 Download stuff 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
4
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
2
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.9.0 <2.0.0