superheros 0.0.3

  • Example
  • Installing
  • Versions
  • 0


Just a list of superheros to be used for the greater good.


import 'package:superheros/superheros.dart';

main() {


Superheros leverages the dart_dev package for most of its tooling needs, including static analysis, code formatting, running tests, collecting coverage, and serving examples. Check out the dart_dev readme for more information.

Testing - pub run dart_dev test

Formatting - pub run dart_dev format



  • Initial version, created by Stagehand


// Copyright (c) 2016, Brady Becker. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:superheros/superheros.dart';

main() {
  print('All the super heros: ${superHeros}');

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  superheros: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:superheros/superheros.dart';
Version Uploaded Documentation Archive
0.0.3 Sep 19, 2016 Go to the documentation of superheros 0.0.3 Download superheros 0.0.3 archive
0.0.2 Sep 19, 2016 Go to the documentation of superheros 0.0.2 Download superheros 0.0.2 archive
0.0.1 Sep 19, 2016 Go to the documentation of superheros 0.0.1 Download superheros 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0