supports_color 0.1.1

  • README.md
  • Installing
  • Versions
  • 31

supports_color pub package Build Status

Detect whether the current terminal supports color.

This is a dart port of the npm supports-color package.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  supports_color: "^0.1.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:supports_color/supports_color.dart';
        
Version Uploaded Documentation Archive
0.1.1 Oct 17, 2014 Go to the documentation of supports_color 0.1.1 Download supports_color 0.1.1 archive
0.1.0 Oct 16, 2014 Go to the documentation of supports_color 0.1.0 Download supports_color 0.1.0 archive

Analysis

We analyzed this package on Apr 9, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.46.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
6 / 100
Health:
Code health derived from static analysis. [more]
92 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
31
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Primary library: package:supports_color/supports_color.dart with components: io.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use supports_color.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 hints.

    Run dartfmt to format lib/src/supports_color.dart.

    Run dartfmt to format lib/supports_color.dart.

Dependencies

Package Constraint Resolved Available
Dev dependencies
unittest >=0.11.0 <0.12.0