Add this to your package's pubspec.yaml file:
dependencies: susi: "^0.1.2"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.2||Nov 3, 2016|
|0.1.1||Sep 11, 2015|
|0.1.0||Sep 11, 2015|
We analyzed this package, and provided a score, details, and suggestions below.
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, other
Strong-mode analysis of
lib/susi.dartfailed with the following error:
line: 38 col: 22
A value of type 'SecureSocket' can't be assigned to a variable of type 'ServerSocket'.
Changelog entries help clients to follow the progress in your code.
Readme should inform others about your project, what it does, and how they can use it.
Fix issues reported by
dartanalyzerreported 1 error(s) and 0 warning(s).
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use