susi 0.1.2

  • Installing
  • Versions
  • 32

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  susi: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:susi/susi.dart';
  
Version Uploaded Documentation Archive
0.1.2 Nov 3, 2016 Go to the documentation of susi 0.1.2 Download susi 0.1.2 archive
0.1.1 Sep 11, 2015 Go to the documentation of susi 0.1.1 Download susi 0.1.1 archive
0.1.0 Sep 11, 2015 Go to the documentation of susi 0.1.0 Download susi 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
12
Overall:
Weighted score of the above. [more]
32
Learn more about scoring.

We analyzed this package on Aug 16, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because susi depends on uuid >=0.0.7 <1.0.3 which requires SDK version <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Add SDK constraint in pubspec.yaml.

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Maintain README.md.

Readme should inform others about your project, what it does, and how they can use it.

Package is getting outdated.

The package was released 93 weeks ago.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use susi.dart.

Format lib/susi.dart.

Run dartfmt to format lib/susi.dart.