sweetalert_angular_dart 0.3.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 27

sweetalert_angular_dart

SweetAlert for Angular Dart.

Demo/Docs

Setup

pubspec.yaml:

dependencies:
  sweetalert_angular_dart: 

HTML:

<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/sweetalert/1.1.3/sweetalert.min.css" />

<script type="text/javascript" src="packages/sweetalert_angular_dart/sweetalert-dev.js"></script>

Dart:

import 'package:sweetalert_angular_dart/sweetalert_angular_dart.dart';

Usage

Dart:

SweetAlert.swal("Good job!", text: "You clicked the button!", type: "success");

Changelog

0.3.0

  • Upgraded angular2 dependency to 4.x.

0.2.0

  • Upgraded angular2 dependency to 3.x

0.1.0

  • Initial version.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sweetalert_angular_dart: ^0.3.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sweetalert_angular_dart/sweetalert_angular_dart.dart';
  
Version Uploaded Documentation Archive
0.3.0 Oct 24, 2017 Go to the documentation of sweetalert_angular_dart 0.3.0 Download sweetalert_angular_dart 0.3.0 archive
0.2.0 May 24, 2017 Go to the documentation of sweetalert_angular_dart 0.2.0 Download sweetalert_angular_dart 0.2.0 archive
0.1.0 Nov 16, 2016 Go to the documentation of sweetalert_angular_dart 0.1.0 Download sweetalert_angular_dart 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
54
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
27
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0