syllables 0.0.4

  • README.md
  • Installing
  • Versions
  • 0

Syllables

A library for working with English syllables.

Examples

Counting syllables

countSyllables('fatal'); // 2
countSyllables('cleaned'); // 1
countSyllables('brilliant-hued'); // 5

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  syllables: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:syllables/syllables.dart';
  
Version Uploaded Documentation Archive
0.0.4 Oct 6, 2017 Go to the documentation of syllables 0.0.4 Download syllables 0.0.4 archive
0.0.3 Oct 6, 2017 Go to the documentation of syllables 0.0.3 Download syllables 0.0.3 archive
0.0.2 Oct 6, 2017 Go to the documentation of syllables 0.0.2 Download syllables 0.0.2 archive
0.0.1 Oct 6, 2017 Go to the documentation of syllables 0.0.1 Download syllables 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: packages.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is getting outdated. (-16.16 points)

The package was released 60 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use syllables.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
packages any 0.4.4
Transitive dependencies
ansicolor 1.0.2
args 1.5.1
console_log_handler 1.1.3
intl 0.15.7
logging 0.11.3+2
optional 3.0.0+2
path 1.6.2
Dev dependencies
test any