A library for working with English syllables.
countSyllables('fatal'); // 2 countSyllables('cleaned'); // 1 countSyllables('brilliant-hued'); // 5
Add this to your package's pubspec.yaml file:
dependencies: syllables: ^0.0.4
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.0.4||Oct 6, 2017|
|0.0.3||Oct 6, 2017|
|0.0.2||Oct 6, 2017|
|0.0.1||Oct 6, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Add SDK constraint in
pubspec.yaml. (-50 points)
For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.
CHANGELOG.md. (-20 points)
Changelog entries help clients to follow the progress in your code.
Use constrained dependencies. (-20 points)
pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies:
The description is too short. (-20 points)
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is getting outdated. (-16.16 points)
The package was released 60 weeks ago.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use
Package is pre-v0.1 release. (-10 points)
While there is nothing inherently wrong with versions of
0.0.*, it usually means that the author is still experimenting with the general direction of the API.