symcrypt 0.0.4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 14

SymCrypt

Simple Symmetric-key encryption for Dart

Usage

A simple usage example:

import 'package:symcrypt/symcrypt.dart' as Symcrypt;

main() {
    String pass = "pass"
    String salt = "salt"
    String pass = Symcrypt.saltData(pass, salt);

    String key = Symcrypt.createHash(pass);
    String data = getData();

    String decrypt = Symcrypt.decrypt(data, key);
    String encrypt = Symcrypt.encrypt(decrypt, key);

    assert(data == encrypt);
}

Changelog

0.0.1

  • Initial version, created by Stagehand

example/symcrypt.dart

// Copyright (c) 2015, <your name>. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

library symcrypt.example;

import 'package:symcrypt/symcrypt.dart' as Symcrypt;

main() {
  String data;
  String key;
  String encryptData;
  String decryptData;

  data = "Toto";
  key = Symcrypt.createHash("Key");
  encryptData = Symcrypt.encrypt(data, key);
  decryptData = Symcrypt.decrypt(encryptData, key);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  symcrypt: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:symcrypt/symcrypt.dart';
  
Version Uploaded Documentation Archive
0.0.4 Aug 28, 2016 Go to the documentation of symcrypt 0.0.4 Download symcrypt 0.0.4 archive
0.0.3 Jul 22, 2016 Go to the documentation of symcrypt 0.0.3 Download symcrypt 0.0.3 archive
0.0.2 Sep 14, 2015 Go to the documentation of symcrypt 0.0.2 Download symcrypt 0.0.2 archive
0.0.1 Sep 10, 2015 Go to the documentation of symcrypt 0.0.1 Download symcrypt 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
29
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
14
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0