symcrypt 0.0.4

  • Example
  • Installing
  • Versions
  • 40


Simple Symmetric-key encryption for Dart


A simple usage example:

import 'package:symcrypt/symcrypt.dart' as Symcrypt;

main() {
    String pass = "pass"
    String salt = "salt"
    String pass = Symcrypt.saltData(pass, salt);

    String key = Symcrypt.createHash(pass);
    String data = getData();

    String decrypt = Symcrypt.decrypt(data, key);
    String encrypt = Symcrypt.encrypt(decrypt, key);

    assert(data == encrypt);



  • Initial version, created by Stagehand


// Copyright (c) 2015, <your name>. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

library symcrypt.example;

import 'package:symcrypt/symcrypt.dart' as Symcrypt;

main() {
  String data;
  String key;
  String encryptData;
  String decryptData;

  data = "Toto";
  key = Symcrypt.createHash("Key");
  encryptData = Symcrypt.encrypt(data, key);
  decryptData = Symcrypt.decrypt(encryptData, key);

1. Depend on it

Add this to your package's pubspec.yaml file:

  symcrypt: "^0.0.4"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:symcrypt/symcrypt.dart';
Version Uploaded Documentation Archive
0.0.4 Aug 28, 2016 Go to the documentation of symcrypt 0.0.4 Download symcrypt 0.0.4 archive
0.0.3 Jul 22, 2016 Go to the documentation of symcrypt 0.0.3 Download symcrypt 0.0.3 archive
0.0.2 Sep 14, 2015 Go to the documentation of symcrypt 0.0.2 Download symcrypt 0.0.2 archive
0.0.1 Sep 10, 2015 Go to the documentation of symcrypt 0.0.1 Download symcrypt 0.0.1 archive


This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1


Describes how popular the package is relative to other packages. [more]
1 / 100
Code health derived from static analysis. [more]
96 / 100
Reflects how tidy and up-to-date the package is. [more]
54 / 100
Overall score:
Weighted score of the above. [more]


Detected platforms: Flutter, other

Primary library: package:symcrypt/symcrypt.dart with components: io.


  • Use constrained dependencies.

    The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: cipher.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
cipher >=0.7.1 0.7.1
crypto >=0.9.0 <2.0.0 1.1.1 2.0.2+1
Transitive dependencies
bignum 0.0.7 0.1.0
charcode 1.1.1
collection 1.14.5
convert 1.1.1 2.0.1
fixnum 0.9.1+2 0.10.6
typed_data 1.1.5
Dev dependencies
test >=0.12.0 <0.13.0