Important Note: This package requires the RawSynchronousSocket class to work, which should become available in version 1.24 of the Dart SDK. If you really want to use this package now, you'll need to use the 1.24-dev SDK.
A simple Dart HTTP client implemented using RawSynchronousSockets to allow for synchronous HTTP requests.
Warning: This library should probably only be used to connect to HTTP servers that are hosted on 'localhost'. The operations in this library will block the calling thread to wait for a response from the HTTP server. The thread can process no other events while waiting for the server to respond. As such, this synchronous HTTP client library is not suitable for applications that require high performance. Instead, such applications should use libraries built on asynchronous I/O, including dart:io and package:http, for the best performance.
Add this to your package's pubspec.yaml file:
dependencies: sync_http: "^0.1.1"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.1||Apr 26, 2017|
|0.1.0||Apr 25, 2017|
We analyzed this package, and provided a score, details, and suggestions below.
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, other
Changelog entries help clients to follow the progress in your code.
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=1.24.0-dev.0.0 <2.0.0|