sync_http 0.1.1

  • Installing
  • Versions
  • 52

Dart Synchronous HTTP Client

Build Status pub package

Important Note: This package requires the RawSynchronousSocket class to work, which should become available in version 1.24 of the Dart SDK. If you really want to use this package now, you'll need to use the 1.24-dev SDK.

A simple Dart HTTP client implemented using RawSynchronousSockets to allow for synchronous HTTP requests.

Warning: This library should probably only be used to connect to HTTP servers that are hosted on 'localhost'. The operations in this library will block the calling thread to wait for a response from the HTTP server. The thread can process no other events while waiting for the server to respond. As such, this synchronous HTTP client library is not suitable for applications that require high performance. Instead, such applications should use libraries built on asynchronous I/O, including dart:io and package:http, for the best performance.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  sync_http: "^0.1.1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:sync_http/sync_http.dart';
Version Uploaded Documentation Archive
0.1.1 Apr 26, 2017 Go to the documentation of sync_http 0.1.1 Download sync_http 0.1.1 archive
0.1.0 Apr 25, 2017 Go to the documentation of sync_http 0.1.0 Download sync_http 0.1.0 archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
24 / 100
Code health derived from static analysis. [more]
87 / 100
Reflects how tidy and up-to-date the package is. [more]
67 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, other

Primary library: package:sync_http/sync_http.dart with components: io.


  • Maintain

    Changelog entries help clients to follow the progress in your code.

  • Package is getting outdated.

    The package was released 59 weeks ago.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 51 hints.

    Strong-mode analysis of lib/src/line_decoder.dart gave the following hint:

    line: 45 col: 17
    'UTF8' is deprecated and shouldn't be used.

    Strong-mode analysis of lib/src/sync_http.dart gave the following hint:

    line: 55 col: 29
    'UTF8' is deprecated and shouldn't be used.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use sync_http.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0-dev.0.0 <2.0.0
Dev dependencies
test >=0.12.0 <0.13.0