Synchronous WebDriver and PageLoader libraries.
This library depends on https://github.com/google/dart-sync-socket which uses a native extension. After doing a pub get or upgrade, you must build the native extension by running:
Projects that use Sync WebDriver should include the following in their pubspec.yaml:
Add this to your package's pubspec.yaml file:
dependencies: sync_webdriver: ^1.2.2+1
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.2.2+1||May 1, 2015|
|1.2.2||Apr 30, 2015|
|1.1.4+1||Feb 25, 2015|
|1.1.4||Feb 20, 2015|
|2.0.0-pre.2||Jun 14, 2016|
|2.0.0-pre.1||May 10, 2016|
|2.0.0-pre.0||May 27, 2015|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc failed. (-10 points)
dartdoc runs without any issues.
|Dart SDK||>=1.9.0 <2.0.0|