sync_webdriver 1.2.2+1

  • README.md
  • Installing
  • Versions
  • 0

Dart Sync WebDriver

Build Status

Synchronous WebDriver and PageLoader libraries.

Installing

This library depends on https://github.com/google/dart-sync-socket which uses a native extension. After doing a pub get or upgrade, you must build the native extension by running:

  # ./packages/sync_socket/../tool/build.sh

Projects that use Sync WebDriver should include the following in their pubspec.yaml:

sync_webdriver: '^1.2.0'

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sync_webdriver: ^1.2.2+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sync_webdriver/sync_webdriver.dart';
  
Version Uploaded Documentation Archive
1.2.2+1 May 1, 2015 Go to the documentation of sync_webdriver 1.2.2+1 Download sync_webdriver 1.2.2+1 archive
1.2.2 Apr 30, 2015 Go to the documentation of sync_webdriver 1.2.2 Download sync_webdriver 1.2.2 archive
1.1.4+1 Feb 25, 2015 Go to the documentation of sync_webdriver 1.1.4+1 Download sync_webdriver 1.1.4+1 archive
1.1.4 Feb 20, 2015 Go to the documentation of sync_webdriver 1.1.4 Download sync_webdriver 1.1.4 archive
2.0.0-pre.2 Jun 14, 2016 Go to the documentation of sync_webdriver 2.0.0-pre.2 Download sync_webdriver 2.0.0-pre.2 archive
2.0.0-pre.1 May 10, 2016 Go to the documentation of sync_webdriver 2.0.0-pre.1 Download sync_webdriver 2.0.0-pre.1 archive
2.0.0-pre.0 May 27, 2015 Go to the documentation of sync_webdriver 2.0.0-pre.0 Download sync_webdriver 2.0.0-pre.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.9.0 <2.0.0