taiga_api 0.0.3

  • README.md
  • Installing
  • Versions
  • 27


library to access taiga api.

taiga_api changelog


  • issue deletion


  • fix push issue


  • use coffee_http
  • fix some bugs


initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  taiga_api: "^0.0.3"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:taiga_api/taiga_api.dart';
Version Uploaded Documentation Archive
0.0.3 Jun 24, 2016 Go to the documentation of taiga_api 0.0.3 Download taiga_api 0.0.3 archive
0.0.2+1 Jun 23, 2016 Go to the documentation of taiga_api 0.0.2+1 Download taiga_api 0.0.2+1 archive
0.0.2 Jun 14, 2016 Go to the documentation of taiga_api 0.0.2 Download taiga_api 0.0.2 archive
0.0.1 Apr 24, 2016 Go to the documentation of taiga_api 0.0.1 Download taiga_api 0.0.1 archive


We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
88 / 100
Reflects how tidy and up-to-date the package is. [more]
3 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, other

Primary library: package:taiga_api/taiga_api.dart with components: io.


  • Use constrained dependencies.

    The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: http.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 error 9 hints.

    Strong-mode analysis of lib/src/issue.dart failed with the following error:

    line: 93 col: 23
    The function expression type '(Map<dynamic, dynamic>) → dynamic' isn't of type '(dynamic) → dynamic'. This means its parameter or return type does not match what is expected. Consider changing parameter type(s) or the returned type(s).

    Run dartfmt to format lib/src/auth.dart.

    Similar analysis of the following files failed:

    • lib/src/core.dart (hint)
    • lib/src/feedbacks.dart (hint)
    • lib/src/milestones.dart (hint)
    • lib/src/resolver.dart (hint)
    • lib/src/tasks.dart (hint)
    • lib/src/users.dart (hint)
  • Package is getting outdated.

    The package was released 102 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use taiga_api.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
coffee_http ^0.2.1 0.2.6+1
http >=0.11.3+5 0.11.3+16
Transitive dependencies
async 2.0.7
charcode 1.1.1
collection 1.14.10
http_parser 3.1.2
path 1.6.0
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5