talkjs 0.0.3

  • Example
  • Installing
  • Versions
  • 58

This is a wrap of talkjs.


You can find an example of how to use this library here



  • Initial version.


import 'dart:html';

import 'package:js/js_util.dart';
import 'package:talkjs/talkjs.dart';

main() async {
  await TalkJs.ready;
  print('talk js is ready');

  final me = new User(
      id: "12345",
      name: "George Looney",
      email: "",
      photoUrl: "",
      welcomeMessage: "Hey there! How are you? :-)");

  final talkSession = new Session("tpR92HU", me);
  setProperty(window, 'talkSession', talkSession.talkJsSession);

  final other = new User(
      id: "54321",
      name: "Ronald Raygun",
      email: "",
      photoUrl: "",
      welcomeMessage: "Hey there! Love to chat :-)");

  final conversation = talkSession.getOrStartConversationWithUser(other);
  final inbox = talkSession.createInbox(
      inboxOptions: new InboxOptions(selected: conversation));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  talkjs: "^0.0.3"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:talkjs/talkjs.dart';
Version Uploaded Documentation Archive
0.0.3 Jun 15, 2018 Go to the documentation of talkjs 0.0.3 Download talkjs 0.0.3 archive
0.0.2 May 29, 2018 Go to the documentation of talkjs 0.0.2 Download talkjs 0.0.2 archive
0.0.1 Feb 6, 2018 Go to the documentation of talkjs 0.0.1 Download talkjs 0.0.1 archive


We analyzed this package on Jun 15, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
17 / 100
Code health derived from static analysis. [more]
100 / 100
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: web

Primary library: package:talkjs/talkjs.dart with components: html, js.


  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
dart_browser_loader ^0.0.4 0.0.4
js ^0.6.1 0.6.1
Dev dependencies
browser ^0.10.0 0.10.0+3
dart_to_js_script_rewriter ^1.0.1
test ^0.12.0