A dart wrapper for the Telegram Bot API (https://core.telegram.org/bots)
Add this to your package's pubspec.yaml file:
dependencies: telegram_bot: "^0.0.6"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.0.6||Oct 6, 2017|
|0.0.5||Feb 6, 2016|
|0.0.4||Feb 6, 2016|
|0.0.3||Feb 6, 2016|
|0.0.2||Feb 6, 2016|
|0.0.1||Feb 5, 2016|
|0.0.0||Feb 5, 2016|
We analyzed this package, and provided a score, details, and suggestions below.
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, other
Strong-mode analysis of
lib/api/api.dartfailed with the following error:
line: 287 col: 40
The method 'map' isn't defined for the class 'Map<String, Object>'.
Changelog entries help clients to follow the progress in your code.
Fix issues reported by
dartanalyzerreported 1 error(s) and 0 warning(s).
Use constrained dependencies.
pubspec.yamlcontains 2 dependencies without version constraints. Specify version ranges for the following dependencies:
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use