telegram_bot 0.0.6

  • README.md
  • Installing
  • Versions
  • 6

dart-telegram-bot-api

A dart wrapper for the Telegram Bot API (https://core.telegram.org/bots)

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  telegram_bot: ^0.0.6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:telegram_bot/telegram_bot.dart';
  
Version Uploaded Documentation Archive
0.0.6 Oct 6, 2017 Go to the documentation of telegram_bot 0.0.6 Download telegram_bot 0.0.6 archive
0.0.5 Feb 6, 2016 Go to the documentation of telegram_bot 0.0.5 Download telegram_bot 0.0.5 archive
0.0.4 Feb 6, 2016 Go to the documentation of telegram_bot 0.0.4 Download telegram_bot 0.0.4 archive
0.0.3 Feb 6, 2016 Go to the documentation of telegram_bot 0.0.3 Download telegram_bot 0.0.3 archive
0.0.2 Feb 6, 2016 Go to the documentation of telegram_bot 0.0.2 Download telegram_bot 0.0.2 archive
0.0.1 Feb 5, 2016 Go to the documentation of telegram_bot 0.0.1 Download telegram_bot 0.0.1 archive
0.0.0 Feb 5, 2016 Go to the documentation of telegram_bot 0.0.0 Download telegram_bot 0.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
7
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
11
Overall:
Weighted score of the above. [more]
6
Learn more about scoring.

We analyzed this package on Oct 21, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.12.4

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because telegram_bot depends on json any which requires SDK version >=0.6.9 <2.0.0, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Add SDK constraint in pubspec.yaml. (-5 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use telegram_bot.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Package is getting outdated. (-4.11 points)

The package was released 54 weeks ago.