test_core 0.2.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new91

test_core

This is a a minimal package for writing and running tests. It also contains extensions for implementing a custom test runner. At this time this package is not intended to be publicly used as the API will take time to stabilize.

0.2.0

  • Remove remote_listener.dart and suite_channel_manager.dart from runner and depend on them from test_api.

0.1.0

  • Initial release of test_core. Provides the basic API for writing and running tests on the VM.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  test_core: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:test_core/test_core.dart';
  
Version Uploaded Documentation Archive
0.2.0 Nov 5, 2018 Go to the documentation of test_core 0.2.0 Download test_core 0.2.0 archive
0.1.0 Nov 3, 2018 Go to the documentation of test_core 0.1.0 Download test_core 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
87
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
91
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6

Platforms

Detected platforms: Flutter, other

Primary library: package:test_core/test_core.dart with components: isolate.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use test_core.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
analyzer >=0.26.4 <0.34.0 0.33.3
args >=1.4.0 <2.0.0 1.5.1
async >=1.13.0 <3.0.0 2.0.8
boolean_selector ^1.0.0 1.0.4
collection ^1.8.0 1.14.11
glob ^1.0.0 1.1.7
io ^0.3.0 0.3.3
matcher >=0.12.3 <0.12.4 0.12.3+1 0.12.4
meta ^1.1.5 1.1.6
package_resolver ^1.0.0 1.0.6
path ^1.2.0 1.6.2
pool ^1.3.0 1.3.6
pub_semver ^1.0.0 1.4.2
source_map_stack_trace ^1.1.4 1.1.5
source_maps ^0.10.2 0.10.8
source_span ^1.4.0 1.4.1
stack_trace ^1.9.0 1.9.3
stream_channel ^1.6.0 1.6.8
test_api 0.2.1 0.2.1
vm_service_client ^0.2.3 0.2.6
yaml ^2.0.0 2.1.15
Transitive dependencies
charcode 1.1.2
convert 2.0.2
crypto 2.0.6
csslib 0.14.6
front_end 0.1.6+3
html 0.13.3+3
http 0.12.0
http_parser 3.1.3
json_rpc_2 2.0.9
kernel 0.3.6+3
logging 0.11.3+2
package_config 1.0.5
plugin 0.2.0+3
string_scanner 1.0.4
term_glyph 1.0.1
typed_data 1.1.6
utf 0.9.0+5
watcher 0.9.7+10
web_socket_channel 1.0.9
Dev dependencies
fake_async >=0.1.2 <2.0.0
pedantic 1.1.0
shelf_test_handler ^1.0.0
test_descriptor ^1.0.0
test_process ^1.0.0