texture_atlas_transformer 1.0.1

  • README.md
  • Installing
  • Versions
  • 42

texture_atlas_transformer

A transformer to build JSON Atlas files for inclusion in games.

Example pubspec.yaml:

transformers:
  - texture_atlas_transformer:
      output_dir: web/assets/textures
      scale: 0.125
      files:
        flying:
          frames:
            - "web/assets/green_flapper/Transparent PNG/flying/*.png"

Options

  • output_dir: Output directory to generate files into.
  • scale: Either a num or a Map (ex. {'x': 0.5, 'y': 1.0}). This ratio is applied to every frame.
  • resize: Same as scale; however, each frame is resized to the exact size, instead of being scaled.
  • files: A Map of Strings to atlas definitions.
  • extension: The output image extension. Default: png. Supports jpg, jpeg, gif, and tga.

Atlas Definitions

  • frames: A List of Strings representing files to be combined. Supports globbing.
  • animations: A Map of Strings to animations.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  texture_atlas_transformer: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:texture_atlas_transformer/texture_atlas_transformer.dart';
  
Version Uploaded Documentation Archive
1.0.1 Jul 26, 2017 Go to the documentation of texture_atlas_transformer 1.0.1 Download texture_atlas_transformer 1.0.1 archive
1.0.0 Jul 25, 2017 Go to the documentation of texture_atlas_transformer 1.0.0 Download texture_atlas_transformer 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
42
Learn more about scoring.

We analyzed this package on Aug 15, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because texture_atlas_transformer depends on barback >=0.6.2 which requires SDK version >=0.6.2 <2.0.0 or >=2.0.0-dev.17.0 <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Package is getting outdated.

The package was released 55 weeks ago.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use texture_atlas_transformer.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0