tiled 0.2.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new63

Tiled Dart

A Dart Tiled library.

Install from Dart Pub Repository

Include the following in your pubspec.yaml:

dependencies:
  tiled: any

Usage

Import the package like this:

import 'package:tiled/tiled.dart'

Load a TMX file into a string by any means, and then pass the string to an instance of TileMapParser.parse:

string tmxBody = /* ... */;
var parser = new TileMapParser();
TileMap map = parser.parse(tmxBody);

Credits

TMX support is work of @radicaled and we have got his code from tmx.dart lib.

0.11.7

  • <object /> tags are now parsed for their type attribute

0.11.5

  • Added support for gzip compression

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  tiled: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:tiled/tiled.dart';
  
Version Uploaded Documentation Archive
0.2.0 Jan 1, 2019 Go to the documentation of tiled 0.2.0 Download tiled 0.2.0 archive
0.1.0 Jan 1, 2019 Go to the documentation of tiled 0.1.0 Download tiled 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
40
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
63
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:tiled/tiled.dart.

Health issues and suggestions

Document public APIs. (-0.44 points)

156 out of 159 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Fix lib/src/layer.dart. (-1.49 points)

Analysis of lib/src/layer.dart reported 3 hints:

line 70 col 13: The value of the local variable 'flipped_horizontally' isn't used.

line 71 col 13: The value of the local variable 'flipped_vertically' isn't used.

line 72 col 13: The value of the local variable 'flipped_diagonally' isn't used.

Fix lib/src/tile_map.dart. (-0.50 points)

Analysis of lib/src/tile_map.dart reported 1 hint:

line 60 col 7: 'onError' is deprecated and shouldn't be used.

Format lib/src/image.dart.

Run dartfmt to format lib/src/image.dart.

Fix additional 4 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/node_dsl.dart (Run dartfmt to format lib/src/node_dsl.dart.)
  • lib/src/object_group.dart (Run dartfmt to format lib/src/object_group.dart.)
  • lib/src/tile_map_parser.dart (Run dartfmt to format lib/src/tile_map_parser.dart.)
  • lib/src/tmx_object.dart (Run dartfmt to format lib/src/tmx_object.dart.)

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use tiled.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.50.0 <3.0.0
archive ^2.0.5 2.0.5
convert ^2.1.1 2.1.1
crypto ^2.0.6 2.0.6
xml ^3.2.3 3.2.5
Transitive dependencies
args 1.5.1
charcode 1.1.2
collection 1.14.11
path 1.6.2
petitparser 2.1.0
typed_data 1.1.6
Dev dependencies
test any