tiles 0.3.2

  • README.md
  • Installing
  • Versions
  • 0


Build Status

Component library to declarative programing of UI in webapp based on Dart language.


For the beta version of docs, see the wiki.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  tiles: ^0.3.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:tiles/tiles.dart';
Version Uploaded Documentation Archive
0.3.2 Jan 30, 2017 Go to the documentation of tiles 0.3.2 Download tiles 0.3.2 archive
0.3.1 May 24, 2016 Go to the documentation of tiles 0.3.1 Download tiles 0.3.1 archive
0.3.0 May 17, 2016 Go to the documentation of tiles 0.3.0 Download tiles 0.3.0 archive
0.2.3 Apr 8, 2016 Go to the documentation of tiles 0.2.3 Download tiles 0.2.3 archive
0.2.2 Feb 1, 2016 Go to the documentation of tiles 0.2.2 Download tiles 0.2.2 archive
0.2.1 Oct 12, 2015 Go to the documentation of tiles 0.2.1 Download tiles 0.2.1 archive
0.2.0+3 Sep 10, 2015 Go to the documentation of tiles 0.2.0+3 Download tiles 0.2.0+3 archive
0.2.0+2 Sep 10, 2015 Go to the documentation of tiles 0.2.0+2 Download tiles 0.2.0+2 archive
0.2.0+1 Jul 29, 2015 Go to the documentation of tiles 0.2.0+1 Download tiles 0.2.0+1 archive
0.2.0 Jul 29, 2015 Go to the documentation of tiles 0.2.0 Download tiles 0.2.0 archive

All 20 versions...

Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because tiles depends on logging >=0.2.8+2 <=0.11.3+1 which requires SDK version <2.0.0, version solving failed.

Health suggestions

Format lib/src/browser/events.dart.

Run dartfmt to format lib/src/browser/events.dart.

Format lib/src/browser/focus.dart.

Run dartfmt to format lib/src/browser/focus.dart.

Format lib/src/browser/mount.dart.

Run dartfmt to format lib/src/browser/mount.dart.

Fix additional 19 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/browser/unmount.dart (Run dartfmt to format lib/src/browser/unmount.dart.)
  • lib/src/browser/updates.dart (Run dartfmt to format lib/src/browser/updates.dart.)
  • lib/src/core/component.dart (Run dartfmt to format lib/src/core/component.dart.)
  • lib/src/core/component_description.dart (Run dartfmt to format lib/src/core/component_description.dart.)
  • lib/src/core/node.dart (Run dartfmt to format lib/src/core/node.dart.)
  • lib/src/core/node_change.dart (Run dartfmt to format lib/src/core/node_change.dart.)
  • lib/src/core/node_update_children.dart (Run dartfmt to format lib/src/core/node_update_children.dart.)
  • lib/src/core/register_component.dart (Run dartfmt to format lib/src/core/register_component.dart.)
  • lib/src/dom/dom_attributes.dart (Run dartfmt to format lib/src/dom/dom_attributes.dart.)
  • lib/src/dom/dom_component.dart (Run dartfmt to format lib/src/dom/dom_component.dart.)
  • lib/src/dom/dom_elements.dart (Run dartfmt to format lib/src/dom/dom_elements.dart.)
  • lib/src/dom/dom_special_elements.dart (Run dartfmt to format lib/src/dom/dom_special_elements.dart.)
  • lib/src/dom/dom_text_component.dart (Run dartfmt to format lib/src/dom/dom_text_component.dart.)
  • lib/src/utils/component_description_factory.dart (Run dartfmt to format lib/src/utils/component_description_factory.dart.)
  • lib/src/utils/component_factory.dart (Run dartfmt to format lib/src/utils/component_factory.dart.)
  • lib/src/utils/node_change_type.dart (Run dartfmt to format lib/src/utils/node_change_type.dart.)
  • lib/tiles.dart (Run dartfmt to format lib/tiles.dart.)
  • lib/tiles_browser.dart (Run dartfmt to format lib/tiles_browser.dart.)
  • lib/tiles_console.dart (Run dartfmt to format lib/tiles_console.dart.)

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-86.85 points)

The package was released 97 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use tiles.dart.