transformer_utils 0.1.5

  • Installing
  • Versions
  • 12

Dart Transformer Utilities

Pub Build Status documentation

Utilities relating to code generation, Dart analyzer, logging, etc. for use in Pub transformers.


This project leverages the dart_dev package for most of its tooling needs, including static analysis, code formatting, running tests, collecting coverage, and serving examples. Check out the dart_dev readme for more information.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  transformer_utils: ^0.1.5

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:transformer_utils/transformer_utils.dart';
Version Uploaded Documentation Archive
0.1.5 Aug 1, 2018 Go to the documentation of transformer_utils 0.1.5 Download transformer_utils 0.1.5 archive
0.1.4 Aug 1, 2018 Go to the documentation of transformer_utils 0.1.4 Download transformer_utils 0.1.4 archive
0.1.3 May 15, 2017 Go to the documentation of transformer_utils 0.1.3 Download transformer_utils 0.1.3 archive
0.1.2 Jan 24, 2017 Go to the documentation of transformer_utils 0.1.2 Download transformer_utils 0.1.2 archive
0.1.1 Feb 5, 2016 Go to the documentation of transformer_utils 0.1.1 Download transformer_utils 0.1.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.2 <2.0.0