transformer_utils 0.1.3

  • README.md
  • Installing
  • Versions
  • 76

Dart Transformer Utilities

Pub Build Status documentation

Utilities relating to code generation, Dart analyzer, logging, etc. for use in Pub transformers.

Development

This project leverages the dart_dev package for most of its tooling needs, including static analysis, code formatting, running tests, collecting coverage, and serving examples. Check out the dart_dev readme for more information.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  transformer_utils: "^0.1.3"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:transformer_utils/transformer_utils.dart';
  
Version Uploaded Documentation Archive
0.1.3 May 15, 2017 Go to the documentation of transformer_utils 0.1.3 Download transformer_utils 0.1.3 archive
0.1.2 Jan 24, 2017 Go to the documentation of transformer_utils 0.1.2 Download transformer_utils 0.1.2 archive
0.1.1 Feb 5, 2016 Go to the documentation of transformer_utils 0.1.1 Download transformer_utils 0.1.1 archive

Analysis

We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
70 / 100
Health:
Code health derived from static analysis. [more]
87 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
73 / 100
Overall score:
Weighted score of the above. [more]
76
Learn more about scoring.

Platforms

Detected platforms: web, other

Primary library: package:transformer_utils/transformer_utils.dart with components: build, mirrors.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 errors 5 hints.

    Strong-mode analysis of lib/src/analyzer_helpers.dart failed with the following error:

    line: 184 col: 50
    The getter 'name' isn't defined for the class 'TypeAnnotation'.

    Strong-mode analysis of lib/src/barback_utils.dart gave the following hint:

    line: 18 col: 1
    'barback' is deprecated and shouldn't be used.

    Similar analysis of the following files failed:

    • lib/src/jet_brains_friendly_logger.dart (hint)
    • lib/src/node_with_meta.dart (hint)
    • lib/src/transformed_source_file.dart (hint)
  • Package is getting outdated.

    The package was released 56 weeks ago.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use transformer_utils.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
analyzer >=0.27.0 <0.31.0 0.30.0+4 0.32.1
barback ^0.15.0 0.15.2+16
path ^1.3.0 1.6.0
source_span ^1.2.0 1.4.0
Transitive dependencies
args 1.4.3
async 2.0.7
charcode 1.1.1
cli_util 0.1.3
collection 1.14.10
convert 2.0.1
crypto 2.0.3
csslib 0.14.4
front_end 0.1.0-alpha.4.1 0.1.1
glob 1.1.5
html 0.13.3+1
isolate 1.1.0 2.0.1
kernel 0.3.0-alpha.1.1 0.3.1
logging 0.11.3+1
meta 1.1.5
package_config 1.0.3
plugin 0.2.0+2
pool 1.3.5
stack_trace 1.9.2
string_scanner 1.0.2
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+8
yaml 2.1.14
Dev dependencies
coverage ^0.7.2
dart_dev ^1.0.6
dart_style ^0.2.2
mockito ^0.11.0
test ^0.12.6