travis_dart 0.1.1

  • README.md
  • Installing
  • Versions
  • 6

travis-dart Build Status

An API wrapper for travis-ci

Features

Full interaction with the travis-ci API v3 is planned

Installation

You can find all the info on https://pub.dartlang.org/packages/travis_dart

Documentation

Create a new instance of the Travis class, it provides a bunch of methods that you can link to the travis-ci API. Real documentation will be provided soon

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  travis_dart: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:travis_dart/models/get/branch.dart';
import 'package:travis_dart/models/get/build.dart';
import 'package:travis_dart/models/get/commit.dart';
import 'package:travis_dart/models/get/error.dart';
import 'package:travis_dart/models/get/job.dart';
import 'package:travis_dart/models/get/organization.dart';
import 'package:travis_dart/models/get/owner.dart';
import 'package:travis_dart/models/get/repository.dart';
import 'package:travis_dart/models/get/stage.dart';
import 'package:travis_dart/models/get/user.dart';
import 'package:travis_dart/models/standard_model.dart';
import 'package:travis_dart/result.dart';
import 'package:travis_dart/travis.dart';
  
Version Uploaded Documentation Archive
0.1.1 May 3, 2018 Go to the documentation of travis_dart 0.1.1 Download travis_dart 0.1.1 archive
0.1.0 May 1, 2018 Go to the documentation of travis_dart 0.1.0 Download travis_dart 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
6
Learn more about scoring.

We analyzed this package on Nov 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.12.5

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because travis_dart depends on dartson >=0.1.1 <1.0.0-alpha which requires SDK version >=0.7.5 <2.0.0, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use travis_dart.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >2.0.0-dev <2.1.0