trello_dart 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

TrelloDart #

A Trello API Client for Dart.

Installation #

add your pubspec.yaml

dependencies:
  trello_dart: '^1.0.0'

Usaage #

import 'package:trello_dart/TrelloDart.dart';

main(List<String> args) async {
  //...
  Client trello = new Client(key /* your key */, token /* your token */);
  // Get your board list
  HttpClientResponse res = await trello.get('1/members/joe_re/boards', {"fields": "name"});
  res.transform(UTF8.decoder).listen((contents) {
    stdout.writeln(contents.toString());
  });

  // Get open list at specify board
  HttpClientResponse res2 = await trello.get('1/boards/57abcdefghijk', { 'lists': 'open', 'list_fields': 'name' });
  res2.transform(UTF8.decoder).listen((contents) {
    stdout.writeln(contents.toString());
  });

  // Create card
  HttpClientResponse res3 = await trello.post('1/cards', { 'idList': '1234567890abcdefg', 'name': 'test', 'desc': 'desctiprion' });
  res3.transform(UTF8.decoder).listen((contents) {
    stdout.writeln(contents.toString());
  });
}

TODO #

  • [ ] attachment file to card
  • [ ] oauth
  • [ ] more easily to use(ex. implements addCard method etc..)
  • [ ] write spec

0.0.1 #

first release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  trello_dart: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:trello_dart/trello_dart.dart';
  
Version Uploaded Documentation Archive
0.0.1 Dec 18, 2016 Go to the documentation of trello_dart 0.0.1 Download trello_dart 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.